CVE-2022-21680
CVE-2022-21680 · Cubic catastrophic backtracking (ReDoS) in marked
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `block.def` may cause catastrophic backtracking against some strings and lead to a regular expression denial of service (ReDoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.
CVSS 7.5 · Élevée · EPSS 2,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
marked
- Versions du logiciel
- < 4.0.10: Concernée
Aucun correctif publié
node-marked Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 4.0.12+ds+~4.0.1-1
Mettez à jour vers 4.0.12+ds+~4.0.1-1
node-marked Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 4.0.12+ds+~4.0.1-1
Mettez à jour vers 4.0.12+ds+~4.0.1-1
node-marked Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 4.0.12+ds+~4.0.1-1
Mettez à jour vers 4.0.12+ds+~4.0.1-1
marked npm
- Plages de versions concernées
- SEMVER: < 4.0.10
Mettez à jour vers 4.0.10
node-marked Ubuntu:16.04:LTS
- Versions du logiciel
- 0.3.2+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:18.04:LTS
- Versions du logiciel
- 0.3.6+dfsg-1
- 0.3.9+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:20.04:LTS
- Versions du logiciel
- 0.5.1+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:22.04:LTS
- Versions du logiciel
- 0.8.0+ds+repack-2
- 0.8.0+ds+repack-3
- 4.0.5+ds-5
- 4.0.9+ds+~4.0.1-2
- 4.0.12+ds+~4.0.1-1
- 4.0.12+ds+~4.0.1-2ubuntu1
- 4.0.12+ds+~4.0.1-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:24.04:LTS
- Versions du logiciel
- 4.2.3+ds+~4.0.7-2ubuntu1
- 4.2.3+ds+~4.0.7-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:25.10
- Versions du logiciel
- 4.2.3+ds+~4.0.7-3
- 4.2.3+ds+~4.0.7-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:26.10
- Versions du logiciel
- 4.2.3+ds+~4.0.7-4
- 4.3.0+ds1+~cs10.2.23-1
- 18.0.5+~cs7.2.17-2
- 18.0.6+~cs7.2.17-1
- 18.0.6+~cs7.2.17-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-marked Ubuntu:26.04:LTS
- Versions du logiciel
- 4.2.3+ds+~4.0.7-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/markedjs/marked/security/advisories/GHSA-rrrm-qjm4-v8hf
- https://github.com/markedjs/marked/commit/c4a3ccd344b6929afa8a1d50ac54a721e57012c0
- https://github.com/markedjs/marked/releases/tag/v4.0.10
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AIXDMC3CSHYW3YWVSQOXAWLUYQHAO5UX/
- https://nvd.nist.gov/vuln/detail/CVE-2022-21680