p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de marked

Vulnérabilité publiée pour marked au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 13

  1. CVE-2026-41680

    Élevée · CVSS 8.7EPSS 0,34%Correctif disponible

    Marked: OOM Denial of Service via Infinite Recursion in marked Tokenizer

    Marked is a markdown parser and compiler. From 18.0.0 to 18.0.1, a critical Denial of Service (DoS) vulnerability exists in marked. By providing a specific 3-byte input sequence a tab, a vertical tab, and a newline (\x09\x0b\n)—an unauthenticated attacker can trigger an infinite recursion loop during parsing. This leads to unbounded memory allocation, causing the host Node.js application to crash via Memory Exhaustion (OOM). This vulnerability is fixed in 18.0.2.

    • Mettez à jour vers 18.0.2
    Publication Mise à jour
  2. CVE-2018-25110

    Moyenne · CVSS 6.9EPSS 0,61%Correctif disponible

    Regular Expression Denial of Service (ReDoS) in markedjs/marked

    Marked prior to version 0.3.17 is vulnerable to a Regular Expression Denial of Service (ReDoS) attack due to catastrophic backtracking in several regular expressions used for parsing HTML tags and markdown links. An attacker can exploit this vulnerability by providing specially crafted markdown input, such as deeply nested or repetitively structured brackets or tag attributes, which cause the parser to hang and lead to a Denial of Service.

    • Mettez à jour vers 0.3.17
    Publication Mise à jour
  3. CVE-2022-21681

    Élevée · CVSS 7.5EPSS 2,77%Correctif disponible

    Exponential catastrophic backtracking (ReDoS) in marked

    Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `inline.reflinkSearch` may cause catastrophic backtracking against some strings and lead to a denial of service (DoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.

    • Mettez à jour vers 4.0.10
    Publication Mise à jour
  4. CVE-2022-21680

    Élevée · CVSS 7.5EPSS 2,85%Correctif disponible

    Cubic catastrophic backtracking (ReDoS) in marked

    Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `block.def` may cause catastrophic backtracking against some strings and lead to a regular expression denial of service (ReDoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.

    • Mettez à jour vers 4.0.10
    Publication Mise à jour
  5. CVE-2021-21306

    Moyenne · CVSS 5.3EPSS 2,46%Correctif disponible

    Denial of Service in Marked

    Marked is an open-source markdown parser and compiler (npm package "marked"). In marked from version 1.1.1 and before version 2.0.0, there is a Regular expression Denial of Service vulnerability. This vulnerability can affect anyone who runs user generated code through marked. This vulnerability is fixed in version 2.0.0.

    • Mettez à jour vers 2.0.0
    Publication Mise à jour
  6. GHSA-ch52-vgq2-943f

    Non évaluéeCorrectif disponible

    Regular Expression Denial of Service in marked

    Affected versions of `marked` are vulnerable to Regular Expression Denial of Service (ReDoS). The `_label` subrule may significantly degrade parsing performance of malformed input. ## Recommendation Upgrade to version 0.7.0 or later.

    • Mettez à jour vers 0.7.0
    Publication Mise à jour
  7. CVE-2014-3743

    Moyenne · CVSS 6.1EPSS 1,71%Correctif disponible

    CVE-2014-3743

    Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.

    • Mettez à jour vers 0.3.1
    Publication Mise à jour
  8. GHSA-xf5p-87ch-gxw2

    Moyenne · CVSS 5.3Correctif disponible

    Marked ReDoS due to email addresses being evaluated in quadratic time

    Versions of `marked` from 0.3.14 until 0.6.2 are vulnerable to Regular Expression Denial of Service. Email addresses may be evaluated in quadratic time, allowing attackers to potentially crash the node process due to resource exhaustion. ## Recommendation Upgrade to version 0.6.2 or later.

    • Mettez à jour vers 0.6.2
    Publication Mise à jour
  9. CVE-2016-10531

    Moyenne · CVSS 6.1EPSS 1,44%Correctif disponible

    CVE-2016-10531

    marked is an application that is meant to parse and compile markdown. Due to the way that marked 0.3.5 and earlier parses input, specifically HTML entities, it's possible to bypass marked's content injection protection (`sanitize: true`) to inject a `javascript:` URL. This flaw exists because `&#xNNanything;` gets parsed to what it could and leaves the rest behind, resulting in just `anything;` being left.

    • Mettez à jour vers 0.3.6
    Publication Mise à jour
  10. CVE-2015-8854

    Élevée · CVSS 7.5EPSS 4,42%Correctif disponible

    CVE-2015-8854

    The marked package before 0.3.4 for Node.js allows attackers to cause a denial of service (CPU consumption) via unspecified vectors that trigger a "catastrophic backtracking issue for the em inline rule," aka a "regular expression denial of service (ReDoS)."

    • Mettez à jour vers 0.3.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →