CVE-2022-24859
CVE-2022-24859 · Manipulated inline images can cause Infinite Loop in PyPDF2
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
PyPDF2 is an open source python PDF library capable of splitting, merging, cropping, and transforming the pages of PDF files. In versions prior to 1.27.5 an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop if the PyPDF2 if the code attempts to get the content stream. The reason is that the last while-loop in `ContentStream._readInlineImage` only terminates when it finds the `EI` token, but never actually checks if the stream has already ended. This issue has been resolved in version `1.27.5`. Users unable to upgrade should validate and PDFs prior to iterating over their content stream.
CVSS 6.2 · Moyenne · EPSS 1,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
pypdf2
- Versions du logiciel
- < 1.27.5: Concernée
Aucun correctif publié
pypdf2 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.27.9-1
Mettez à jour vers 1.27.9-1
pypdf2 PyPI
- Versions du logiciel
- 1.15
- 1.16
- 1.17
- 1.18
- 1.19
- 1.20
- 1.21
- 1.22
- 1.23
- 1.24
- 1.25
- 1.25.1
- 1.26.0
- 1.27.0
- 1.27.1
- 1.27.2
- 1.27.3
- 1.27.4
- Plages de versions concernées
- ECOSYSTEM: < 1.27.5
Mettez à jour vers 1.27.5
pypdf2 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.23+git20141008-1
- 1.25.1-1
- Plages de versions concernées
- ECOSYSTEM: < 1.25.1-1ubuntu0.1~esm1
Mettez à jour vers 1.25.1-1ubuntu0.1~esm1
pypdf2 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.26.0-2
- Plages de versions concernées
- ECOSYSTEM: < 1.26.0-2ubuntu0.1~esm1
Mettez à jour vers 1.26.0-2ubuntu0.1~esm1
pypdf2 Ubuntu:20.04:LTS
- Versions du logiciel
- 1.26.0-2
- 1.26.0-3ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 1.26.0-3ubuntu1.20.04.1
Mettez à jour vers 1.26.0-3ubuntu1.20.04.1
pypdf2 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.26.0-4
- Plages de versions concernées
- ECOSYSTEM: < 1.26.0-4ubuntu0.22.04.1
Mettez à jour vers 1.26.0-4ubuntu0.22.04.1
Sources originales
- https://github.com/py-pdf/PyPDF2/security/advisories/GHSA-xcjx-m2pj-8g79
- https://github.com/py-pdf/PyPDF2/issues/329
- https://github.com/py-pdf/PyPDF2/pull/740
- https://github.com/py-pdf/PyPDF2/releases/tag/1.27.5
- https://lists.debian.org/debian-lts-announce/2022/06/msg00001.html
- https://lists.debian.org/debian-lts-announce/2023/06/msg00013.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-24859