CVE-2022-24859
CVE-2022-24859 · Manipulated inline images can cause Infinite Loop in PyPDF2
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
PyPDF2 is an open source python PDF library capable of splitting, merging, cropping, and transforming the pages of PDF files. In versions prior to 1.27.5 an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop if the PyPDF2 if the code attempts to get the content stream. The reason is that the last while-loop in `ContentStream._readInlineImage` only terminates when it finds the `EI` token, but never actually checks if the stream has already ended. This issue has been resolved in version `1.27.5`. Users unable to upgrade should validate and PDFs prior to iterating over their content stream.
CVSS 6.2 · Mittel · EPSS 1,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pypdf2
- Softwareversionen
- < 1.27.5: Betroffen
Keine Korrektur veröffentlicht
pypdf2 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.27.9-1
Auf 1.27.9-1 aktualisieren
pypdf2 PyPI
- Softwareversionen
- 1.15
- 1.16
- 1.17
- 1.18
- 1.19
- 1.20
- 1.21
- 1.22
- 1.23
- 1.24
- 1.25
- 1.25.1
- 1.26.0
- 1.27.0
- 1.27.1
- 1.27.2
- 1.27.3
- 1.27.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.27.5
Auf 1.27.5 aktualisieren
pypdf2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.23+git20141008-1
- 1.25.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.25.1-1ubuntu0.1~esm1
Auf 1.25.1-1ubuntu0.1~esm1 aktualisieren
pypdf2 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.26.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.26.0-2ubuntu0.1~esm1
Auf 1.26.0-2ubuntu0.1~esm1 aktualisieren
pypdf2 Ubuntu:20.04:LTS
- Softwareversionen
- 1.26.0-2
- 1.26.0-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.26.0-3ubuntu1.20.04.1
Auf 1.26.0-3ubuntu1.20.04.1 aktualisieren
pypdf2 Ubuntu:22.04:LTS
- Softwareversionen
- 1.26.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.26.0-4ubuntu0.22.04.1
Auf 1.26.0-4ubuntu0.22.04.1 aktualisieren
Originalquellen
- https://github.com/py-pdf/PyPDF2/security/advisories/GHSA-xcjx-m2pj-8g79
- https://github.com/py-pdf/PyPDF2/issues/329
- https://github.com/py-pdf/PyPDF2/pull/740
- https://github.com/py-pdf/PyPDF2/releases/tag/1.27.5
- https://lists.debian.org/debian-lts-announce/2022/06/msg00001.html
- https://lists.debian.org/debian-lts-announce/2023/06/msg00013.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-24859