CVE-2022-31043
CVE-2022-31043 · Fix failure to strip Authorization header on HTTP downgrade in Guzzle
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.
CVSS 7.5 · Élevée · EPSS 2,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
guzzle
- Versions du logiciel
- < 6.5.7: Concernée
- >=7.0.0, < 7.4.4: Concernée
Aucun correctif publié
guzzle Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 7.4.4-1
Mettez à jour vers 7.4.4-1
guzzle Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 7.4.4-1
Mettez à jour vers 7.4.4-1
guzzle Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 7.4.4-1
Mettez à jour vers 7.4.4-1
mediawiki Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1:1.35.7-1
Mettez à jour vers 1:1.35.7-1
mediawiki Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1:1.35.7-1
Mettez à jour vers 1:1.35.7-1
mediawiki Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1:1.35.7-1
Mettez à jour vers 1:1.35.7-1
guzzle Ubuntu:24.04:LTS
- Versions du logiciel
- 7.4.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
guzzle Ubuntu:25.10
- Versions du logiciel
- 7.9.2-0.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
guzzle Ubuntu:26.10
- Versions du logiciel
- 7.9.2-0.1build1
- 7.13.1-1
- 7.15.1-1
- 7.15.2-1
- 7.15.3-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
guzzle Ubuntu:26.04:LTS
- Versions du logiciel
- 7.9.2-0.1
- 7.9.2-0.1build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/guzzle/guzzle/commit/e3ff079b22820c2029d4c2a87796b6a0b8716ad8
- https://www.rfc-editor.org/rfc/rfc9110.html#name-redirection-3xx
- https://github.com/guzzle/guzzle/security/advisories/GHSA-w248-ffj2-4v5q
- https://www.drupal.org/sa-core-2022-011
- https://www.debian.org/security/2022/dsa-5246
- https://nvd.nist.gov/vuln/detail/CVE-2022-31043