CVE-2022-31043
CVE-2022-31043 · Fix failure to strip Authorization header on HTTP downgrade in Guzzle
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.
CVSS 7.5 · Hoch · EPSS 2,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
guzzle
- Softwareversionen
- < 6.5.7: Betroffen
- >=7.0.0, < 7.4.4: Betroffen
Keine Korrektur veröffentlicht
guzzle Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.4.4-1
Auf 7.4.4-1 aktualisieren
guzzle Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.4.4-1
Auf 7.4.4-1 aktualisieren
guzzle Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.4.4-1
Auf 7.4.4-1 aktualisieren
mediawiki Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.35.7-1
Auf 1:1.35.7-1 aktualisieren
mediawiki Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.35.7-1
Auf 1:1.35.7-1 aktualisieren
mediawiki Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.35.7-1
Auf 1:1.35.7-1 aktualisieren
guzzle Ubuntu:24.04:LTS
- Softwareversionen
- 7.4.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
guzzle Ubuntu:25.10
- Softwareversionen
- 7.9.2-0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
guzzle Ubuntu:26.10
- Softwareversionen
- 7.9.2-0.1build1
- 7.13.1-1
- 7.15.1-1
- 7.15.2-1
- 7.15.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
guzzle Ubuntu:26.04:LTS
- Softwareversionen
- 7.9.2-0.1
- 7.9.2-0.1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/guzzle/guzzle/commit/e3ff079b22820c2029d4c2a87796b6a0b8716ad8
- https://www.rfc-editor.org/rfc/rfc9110.html#name-redirection-3xx
- https://github.com/guzzle/guzzle/security/advisories/GHSA-w248-ffj2-4v5q
- https://www.drupal.org/sa-core-2022-011
- https://www.debian.org/security/2022/dsa-5246
- https://nvd.nist.gov/vuln/detail/CVE-2022-31043