CVE-2022-31175
CVE-2022-31175 · Cross-site scripting caused by the editor instance destroying process in ckeditor5
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.
CVSS 5.8 · Moyenne · EPSS 0,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
ckeditor5
- Versions du logiciel
- < 35.0.1: Concernée
Aucun correctif publié
@ckeditor/ckeditor5-markdown-gfm npm
- Plages de versions concernées
- SEMVER: < 35.0.1
Mettez à jour vers 35.0.1
@ckeditor/ckeditor5-html-support npm
- Plages de versions concernées
- SEMVER: < 35.0.1
Mettez à jour vers 35.0.1
@ckeditor/ckeditor5-html-embed npm
- Plages de versions concernées
- SEMVER: < 35.0.1
Mettez à jour vers 35.0.1
ldap-account-manager Ubuntu:16.04:LTS
- Versions du logiciel
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:16.04:LTS
- Versions du logiciel
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ckeditor3 Ubuntu:18.04:LTS
- Versions du logiciel
- 3.6.6.1+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ldap-account-manager Ubuntu:18.04:LTS
- Versions du logiciel
- 5.7-1
- 6.1-1
- 6.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ckeditor3 Ubuntu:20.04:LTS
- Versions du logiciel
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ldap-account-manager Ubuntu:20.04:LTS
- Versions du logiciel
- 6.7-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:20.04:LTS
- Versions du logiciel
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ckeditor3 Ubuntu:22.04:LTS
- Versions du logiciel
- 3.6.6.1+dfsg-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ldap-account-manager Ubuntu:22.04:LTS
- Versions du logiciel
- 7.5-1
- 7.7-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:22.04:LTS
- Versions du logiciel
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ckeditor3 Ubuntu:24.04:LTS
- Versions du logiciel
- 3.6.6.1+dfsg-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ldap-account-manager Ubuntu:24.04:LTS
- Versions du logiciel
- 8.3-1
- 8.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:24.04:LTS
- Versions du logiciel
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ldap-account-manager Ubuntu:25.10
- Versions du logiciel
- 9.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:25.10
- Versions du logiciel
- 4.4.7+dfsg-4syncable1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ldap-account-manager Ubuntu:26.04:LTS
- Versions du logiciel
- 9.0-1
- 9.0-1build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
request-tracker4 Ubuntu:26.04:LTS
- Versions du logiciel
- 4.4.7+dfsg-4syncable1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-42wq-rch8-6f6j
- https://ckeditor.com/docs/ckeditor5/latest/features/general-html-support.html
- https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.html
- https://ckeditor.com/docs/ckeditor5/latest/features/markdown.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-31175