CVE-2022-31175
CVE-2022-31175 · Cross-site scripting caused by the editor instance destroying process in ckeditor5
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.
CVSS 5.8 · Mittel · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
ckeditor5
- Softwareversionen
- < 35.0.1: Betroffen
Keine Korrektur veröffentlicht
@ckeditor/ckeditor5-markdown-gfm npm
- Betroffene Versionsbereiche
- SEMVER: < 35.0.1
Auf 35.0.1 aktualisieren
@ckeditor/ckeditor5-html-support npm
- Betroffene Versionsbereiche
- SEMVER: < 35.0.1
Auf 35.0.1 aktualisieren
@ckeditor/ckeditor5-html-embed npm
- Betroffene Versionsbereiche
- SEMVER: < 35.0.1
Auf 35.0.1 aktualisieren
ldap-account-manager Ubuntu:16.04:LTS
- Softwareversionen
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:16.04:LTS
- Softwareversionen
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:18.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:18.04:LTS
- Softwareversionen
- 5.7-1
- 6.1-1
- 6.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:20.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:20.04:LTS
- Softwareversionen
- 6.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:20.04:LTS
- Softwareversionen
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:22.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:22.04:LTS
- Softwareversionen
- 7.5-1
- 7.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:22.04:LTS
- Softwareversionen
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:24.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:24.04:LTS
- Softwareversionen
- 8.3-1
- 8.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:24.04:LTS
- Softwareversionen
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:25.10
- Softwareversionen
- 9.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:25.10
- Softwareversionen
- 4.4.7+dfsg-4syncable1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:26.04:LTS
- Softwareversionen
- 9.0-1
- 9.0-1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:26.04:LTS
- Softwareversionen
- 4.4.7+dfsg-4syncable1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-42wq-rch8-6f6j
- https://ckeditor.com/docs/ckeditor5/latest/features/general-html-support.html
- https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.html
- https://ckeditor.com/docs/ckeditor5/latest/features/markdown.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-31175