p PatchFirst

CVE-2022-41938

CVE-2022-41938 · Cross site scripting vulnerability with discussion titles in flarum

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Flarum is an open source discussion platform. Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after `v1.5` and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. All communities running Flarum from `v1.5.0` to `v1.6.1` are impacted. The vulnerability has been fixed and published as flarum/core `v1.6.2`. All communities running Flarum from `v1.5.0` to `v1.6.1` have to upgrade as soon as possible to v1.6.2. There are no known workarounds for this issue.

CVSS 9.0 · Critique · EPSS 0,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • framework

    Versions du logiciel
    • >= 1.5.0, < 1.6.2: Concernée

    Aucun correctif publié

  • flarum/core Packagist

    Versions du logiciel
    • v1.5.0
    • v1.6.0
    • v1.6.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.5.0, < 1.6.2

    Mettez à jour vers 1.6.2

Sources originales

Vérifiez votre serveur →