CVE-2022-41938
CVE-2022-41938 · Cross site scripting vulnerability with discussion titles in flarum
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Flarum is an open source discussion platform. Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after `v1.5` and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. All communities running Flarum from `v1.5.0` to `v1.6.1` are impacted. The vulnerability has been fixed and published as flarum/core `v1.6.2`. All communities running Flarum from `v1.5.0` to `v1.6.1` have to upgrade as soon as possible to v1.6.2. There are no known workarounds for this issue.
CVSS 9.0 · Critical · EPSS 0.8% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
framework
- Versions
- >= 1.5.0, < 1.6.2: Affected
No fix published
flarum/core Packagist
- Versions
- v1.5.0
- v1.6.0
- v1.6.1
- Affected ranges
- ECOSYSTEM: ≥ 1.5.0, < 1.6.2
Update to 1.6.2