p PatchFirst

CVE-2022-45151

CVE-2022-45151

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

CVSS 5.4 · Moyenne · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · php

Produits et versions concernés

  • moodle

    Versions du logiciel
    • Fixed in moodle 4.0.5, moodle 3.11.11: Concernée

    Aucun correctif publié

  • moodle/moodle Packagist

    Versions du logiciel
    • v3.11.0
    • v3.11.0-beta
    • v3.11.0-rc1
    • v3.11.0-rc2
    • v3.11.1
    • v3.11.10
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    • v3.11.8
    • v3.11.9
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.11, < 3.11.11

    Mettez à jour vers 3.11.11

  • moodle/moodle Packagist

    Versions du logiciel
    • v4.0.0
    • v4.0.0-beta
    • v4.0.0-rc1
    • v4.0.0-rc2
    • v4.0.0-rc3
    • v4.0.0-rc4
    • v4.0.1
    • v4.0.2
    • v4.0.3
    • v4.0.4
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.0, < 4.0.5

    Mettez à jour vers 4.0.5

  • moodle Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • moodle Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →