p PatchFirst

CVE-2022-45151

CVE-2022-45151

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

CVSS 5.4 · Medium · EPSS 0.7% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • Fixed in moodle 4.0.5, moodle 3.11.11: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.11.0
    • v3.11.0-beta
    • v3.11.0-rc1
    • v3.11.0-rc2
    • v3.11.1
    • v3.11.10
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    • v3.11.8
    • v3.11.9
    Affected ranges
    • ECOSYSTEM: ≥ 3.11, < 3.11.11

    Update to 3.11.11

  • moodle/moodle Packagist

    Versions
    • v4.0.0
    • v4.0.0-beta
    • v4.0.0-rc1
    • v4.0.0-rc2
    • v4.0.0-rc3
    • v4.0.0-rc4
    • v4.0.1
    • v4.0.2
    • v4.0.3
    • v4.0.4
    Affected ranges
    • ECOSYSTEM: ≥ 4.0, < 4.0.5

    Update to 4.0.5

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →