p PatchFirst

CVE-2023-23613

CVE-2023-23613 · Field-level security issue with .keyword fields in OpenSearch

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.

CVSS 5.7 · Moyenne · EPSS 0,8%

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • security

    Versions du logiciel
    • >= 2.0.0, < 2.5.0: Concernée
    • < 1.3.8: Concernée

    Aucun correctif publié

  • opensearch Ubuntu:24.04:LTS

    Versions du logiciel
    • 2.4.1+dfsg-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →