p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de opensearch

Vulnérabilité publiée pour opensearch au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 6

  1. CVE-2026-43826

    Moyenne · CVSS 6.5EPSS 0,41%Aucun correctif publié

    Apache Airflow Providers OpenSearch: OpenSearch task-log handler leaks credentials embedded in the host URL

    The OpenSearch logging provider, when configured with a `host` URL that embeds credentials (for example `https://user:[email protected]:9200`), wrote the full host URL — including the embedded credentials — into task logs. Any user with task-log read permission could harvest the backend credentials. Users are advised to upgrade to `apache-airflow-providers-opensearch` 1.9.1 or later and, as a defense-in-depth measure, configure the backend credentials via a secret backend rather than embedding them in the `[opensearch] host` URL.

    Publication Mise à jour
  2. CVE-2023-45807

    Moyenne · CVSS 5.4EPSS 0,49%Aucun correctif publié

    OpenSearch Issue with tenant read-only permissions

    OpenSearch is a community-driven, open source fork of Elasticsearch and Kibana following the license change in early 2021. There is an issue with the implementation of tenant permissions in OpenSearch Dashboards where authenticated users with read-only access to a tenant can perform create, edit and delete operations on index metadata of dashboards and visualizations in that tenant, potentially rendering them unavailable. This issue does not affect index data, only metadata. Dashboards correctly enforces read-only permissions when indexing and updating documents. This issue does not provide additional read access to data users don’t already h

    Publication Mise à jour
  3. CVE-2023-31141

    Moyenne · CVSS 4.8EPSS 0,46%Aucun correctif publié

    OpenSearch issue with fine-grained access control during extremely rare race conditions

    OpenSearch is open-source software suite for search, analytics, and observability applications. Prior to versions 1.3.10 and 2.7.0, there is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the queries during extremely rare race conditions potentially leading to incorrect access authorization. For this issue to be triggered, two concurrent requests need to land on the same instance exactly when query cache eviction happens, once every four hours. OpenSearch 1.3.10 and 2.7.0 contain a fix for this issue.

    Publication Mise à jour
  4. CVE-2023-23612

    Moyenne · CVSS 4.7EPSS 0,8%Aucun correctif publié

    Issue with whitespace in JWT roles in OpenSearch

    OpenSearch is an open source distributed and RESTful search engine. OpenSearch uses JWTs to store role claims obtained from the Identity Provider (IdP) when the authentication backend is SAML or OpenID Connect. There is an issue in how those claims are processed from the JWTs where the leading and trailing whitespace is trimmed, allowing users to potentially claim roles they are not assigned to if any role matches the whitespace-stripped version of the roles they are a member of. This issue is only present for authenticated users, and it requires either the existence of roles that match, not considering leading/trailing whitespace, or the abi

    Publication Mise à jour
  5. CVE-2023-23613

    Moyenne · CVSS 5.7EPSS 0,82%Aucun correctif publié

    Field-level security issue with .keyword fields in OpenSearch

    OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade ma

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →