p PatchFirst

CVE-2023-35165

CVE-2023-35165 · AWS CDK EKS overly permissive trust policies

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

AWS Cloud Development Kit (AWS CDK) is an open-source software development framework to define cloud infrastructure in code and provision it through AWS CloudFormation. In the packages `aws-cdk-lib` 2.0.0 until 2.80.0 and `@aws-cdk/aws-eks` 1.57.0 until 1.202.0, `eks.Cluster` and `eks.FargateCluster` constructs create two roles, `CreationRole` and `default MastersRole`, that have an overly permissive trust policy. The first, referred to as the `CreationRole`, is used by lambda handlers to create the cluster and deploy Kubernetes resources (e.g `KubernetesManifest`, `HelmChart`, ...) onto it. Users with CDK version higher or equal to 1.62.0 (including v2 users) may be affected. The second, referred to as the `default MastersRole`, is provisioned only if the `mastersRole` property isn't provided and has permissions to execute `kubectl` commands on the cluster. Users with CDK version higher or equal to 1.57.0 (including v2 users) may be affected. The issue has been fixed in `@aws-cdk/aws-eks` v1.202.0 and `aws-cdk-lib` v2.80.0. These versions no longer use the account root principal. Instead, they restrict the trust policy to the specific roles of lambda handlers that need it. There is no workaround available for CreationRole. To avoid creating the `default MastersRole`, use the `mastersRole` property to explicitly provide a role.

CVSS 6.6 · Moyenne · EPSS 0,9% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • aws-cdk

    Versions du logiciel
    • aws-cdk-lib >= 2.0.0, < 2.80.0: Concernée
    • @aws-cdk/aws-eks >= 1.57.0, < 1.202.0: Concernée

    Aucun correctif publié

  • aws-cdk-lib npm

    Plages de versions concernées
    • SEMVER: ≥ 2.0.0, < 2.80.0

    Mettez à jour vers 2.80.0

  • @aws-cdk/aws-eks npm

    Plages de versions concernées
    • SEMVER: ≥ 1.57.0, < 1.202.0

    Mettez à jour vers 1.202.0

Sources originales

Vérifiez votre serveur →