p PatchFirst

CVE-2023-36478

CVE-2023-36478 · HTTP/2 HPACK integer overflow and buffer allocation

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295 will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.

CVSS 7.5 · Élevée · EPSS 4,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • jetty.project

    Versions du logiciel
    • >= 10.0.0, < 10.0.16: Concernée
    • >= 11.0.0, < 11.0.16: Concernée
    • >= 9.3.0, < 9.4.53: Concernée

    Aucun correctif publié

  • jetty9 Debian:12

    Versions du logiciel
    • 9.4.50-4
    • 9.4.50-4+deb12u1
    Plages de versions concernées
    • ECOSYSTEM: < 9.4.50-4+deb12u2

    Mettez à jour vers 9.4.50-4+deb12u2

  • jetty9 Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 9.4.53-1

    Mettez à jour vers 9.4.53-1

  • jetty9 Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 9.4.53-1

    Mettez à jour vers 9.4.53-1

  • jetty Ubuntu:14.04:LTS

    Versions du logiciel
    • 6.1.26-1ubuntu1
    • 6.1.26-1ubuntu1.1
    • 6.1.26-1ubuntu1.2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • jetty Ubuntu:16.04:LTS

    Versions du logiciel
    • 6.1.26-5
    • 6.1.26-5ubuntu0.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →