CVE-2023-36478
CVE-2023-36478 · HTTP/2 HPACK integer overflow and buffer allocation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295 will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.
CVSS 7.5 · High · EPSS 4.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
jetty.project
- Versions
- >= 10.0.0, < 10.0.16: Affected
- >= 11.0.0, < 11.0.16: Affected
- >= 9.3.0, < 9.4.53: Affected
No fix published
jetty9 Debian:12
- Versions
- 9.4.50-4
- 9.4.50-4+deb12u1
- Affected ranges
- ECOSYSTEM: < 9.4.50-4+deb12u2
Update to 9.4.50-4+deb12u2
jetty9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.4.53-1
Update to 9.4.53-1
jetty9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.4.53-1
Update to 9.4.53-1
jetty Ubuntu:14.04:LTS
- Versions
- 6.1.26-1ubuntu1
- 6.1.26-1ubuntu1.1
- 6.1.26-1ubuntu1.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jetty Ubuntu:16.04:LTS
- Versions
- 6.1.26-5
- 6.1.26-5ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-wgh7-54f2-x98r
- https://github.com/eclipse/jetty.project/pull/9634
- https://github.com/eclipse/jetty.project/releases/tag/jetty-10.0.16
- https://github.com/eclipse/jetty.project/releases/tag/jetty-11.0.16
- https://github.com/eclipse/jetty.project/releases/tag/jetty-9.4.53.v20231009
- http://www.openwall.com/lists/oss-security/2023/10/18/4
- https://lists.debian.org/debian-lts-announce/2023/10/msg00045.html
- https://www.debian.org/security/2023/dsa-5540
- https://security.netapp.com/advisory/ntap-20231116-0011/
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://nvd.nist.gov/vuln/detail/CVE-2023-36478