p PatchFirst

CVE-2023-37941

CVE-2023-37941 · Apache Superset: Metadata db write access can lead to remote code execution

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

CVSS 6.6 · Moyenne · EPSS 35,5% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • apache superset

    Versions du logiciel
    • ≥ 1.5.0, ≤ 2.1.0: Concernée (semver)

    Aucun correctif publié

  • apache-superset PyPI

    Versions du logiciel
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.5.0, < 2.1.1

    Mettez à jour vers 2.1.1

Sources originales

Vérifiez votre serveur →