CVE-2023-37941
CVE-2023-37941 · Apache Superset: Metadata db write access can lead to remote code execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.
CVSS 6.6 · Medium · EPSS 35.5% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ 1.5.0, ≤ 2.1.0: Affected (semver)
No fix published
apache-superset PyPI
- Versions
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- Affected ranges
- ECOSYSTEM: ≥ 1.5.0, < 2.1.1
Update to 2.1.1