p PatchFirst

CVE-2023-42460

CVE-2023-42460 · _abi_decode input not validated in complex expressions in Vyper

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.

CVSS 5.3 · Moyenne · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • vyper

    Versions du logiciel
    • >= 0.3.4, < 0.3.10: Concernée

    Aucun correctif publié

  • vyper PyPI

    Versions du logiciel
    • 0.3.10rc1
    • 0.3.10rc2
    • 0.3.10rc3
    • 0.3.10rc4
    • 0.3.10rc5
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.3.8
    • 0.3.9
    Plages de versions concernées
    • ECOSYSTEM: ≥ 0.3.4, < 0.3.10

    Mettez à jour vers 0.3.10

Sources originales

Vérifiez votre serveur →