p PatchFirst

CVE-2023-42460

CVE-2023-42460 · _abi_decode input not validated in complex expressions in Vyper

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.

CVSS 5.3 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • vyper

    Softwareversionen
    • >= 0.3.4, < 0.3.10: Betroffen

    Keine Korrektur veröffentlicht

  • vyper PyPI

    Softwareversionen
    • 0.3.10rc1
    • 0.3.10rc2
    • 0.3.10rc3
    • 0.3.10rc4
    • 0.3.10rc5
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.3.8
    • 0.3.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.3.4, < 0.3.10

    Auf 0.3.10 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →