CVE-2024-24577
CVE-2024-24577 · libgit2 is vulnerable to arbitrary code execution due to heap corruption in `git_index_add`
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_index_add` can cause heap corruption that could be leveraged for arbitrary code execution. There is an issue in the `has_dir_name` function in `src/libgit2/index.c`, which frees an entry that should not be freed. The freed entry is later used and overwritten with potentially bad actor-controlled data leading to controlled heap corruption. Depending on the application that uses libgit2, this could lead to arbitrary code execution. This issue has been patched in version 1.6.5 and 1.7.2.
CVSS 8.6 · Élevée · EPSS 1,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libgit2
- Versions du logiciel
- < 1.6.5: Concernée
- >= 1.7.0, < 1.7.2: Concernée
Aucun correctif publié
libgit2 Debian:12
- Versions du logiciel
- 1.5.1+ds-1
- Plages de versions concernées
- ECOSYSTEM: < 1.5.1+ds-1+deb12u1
Mettez à jour vers 1.5.1+ds-1+deb12u1
libgit2 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.7.2+ds-1
Mettez à jour vers 1.7.2+ds-1
libgit2 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.7.2+ds-1
Mettez à jour vers 1.7.2+ds-1
libgit2 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.22.2-2
- 0.23.1-1
- 0.24.1-2
- 0.24.1-2ubuntu0.2
- 0.24.1-2ubuntu0.2+esm1
- Plages de versions concernées
- ECOSYSTEM: < 0.24.1-2ubuntu0.2+esm2
Mettez à jour vers 0.24.1-2ubuntu0.2+esm2
libgit2 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 0.25.1+really0.24.6-1
- 0.26.0+dfsg.1-1.1
- 0.26.0+dfsg.1-1.1build1
- 0.26.0+dfsg.1-1.1ubuntu0.2
- Plages de versions concernées
- ECOSYSTEM: < 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
libgit2 Ubuntu:20.04:LTS
- Versions du logiciel
- 0.27.7+dfsg.1-0.2build1
- 0.28.3+dfsg.1-1
- 0.28.3+dfsg.1-1ubuntu1
- 0.28.4+dfsg.1-2
- Plages de versions concernées
- ECOSYSTEM: < 0.28.4+dfsg.1-2ubuntu0.1
Mettez à jour vers 0.28.4+dfsg.1-2ubuntu0.1
libgit2 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.1.0+dfsg.1-4
- 1.1.0+dfsg.1-4.1
- 1.1.0+dfsg.1-4.1build1
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0+dfsg.1-4.1ubuntu0.1
Mettez à jour vers 1.1.0+dfsg.1-4.1ubuntu0.1
Sources originales
- https://github.com/libgit2/libgit2/security/advisories/GHSA-j2v7-4f6v-gpg8
- https://github.com/libgit2/libgit2/releases/tag/v1.6.5
- https://github.com/libgit2/libgit2/releases/tag/v1.7.2
- https://lists.fedoraproject.org/archives/list/[email protected]/message/S635BGHHZUMRPI7QOXOJ45QHDD5FFZ3S/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/4M3P7WIEPXNRLBINQRJFXUSTNKBCHYC7/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/7CNDW3PF6NHO7OXNM5GN6WSSGAMA7MZE/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/Z6MXOX7I43OWNN7R6M54XLG6U5RXY244/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZGNHOEE2RBLH7KCJUPUNYG4CDTW4HTBT/
- https://lists.debian.org/debian-lts-announce/2024/02/msg00012.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-24577