p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de libgit2

Vulnérabilités publiées pour libgit2 au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 11

  1. CVE-2026-53583

    Moyenne · CVSS 6.5EPSS 0,24%Aucun correctif publié

    libgit2: Inverted IP SubjectAltName Comparison in OpenSSL Backend

    libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, verify_server_cert in src/libgit2/streams/openssl.c uses an inverted !!memcmp result in the GEN_IPADD branch when comparing an IP-literal host with a certificate IP SubjectAltName. OpenSSL builds reject matching IP addresses and accept mismatched IP addresses, allowing a network attacker with a CA-trusted certificate containing any IP SubjectAltName to intercept libgit2 connections to IP-literal HTTPS URLs. DNS SubjectAltName validation and non-Open

    Publication Mise à jour
  2. CVE-2026-53585

    Moyenne · CVSS 5.3EPSS 0,4%Correctif disponible

    libgit2: Unbounded Memory Allocation via Delta Object Result-Size Header

    libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, git_delta_apply in src/libgit2/delta.c trusts the attacker-controlled res_sz value parsed by hdr_sz from a delta object header and passes that amount to git__malloc before validating delta instructions. Malicious pack data supplied through git_clone, git_fetch, git_remote_fetch, git_indexer_append, or a local attacker-supplied repository can use a very small multi-level OFS_DELTA chain to retain extremely large allocations and exhaust memory. This i

    • Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm2
    Publication Mise à jour
  3. CVE-2026-53584

    Moyenne · CVSS 4.3EPSS 0,33%Aucun correctif publié

    libgit2: Submodule path traversal

    libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, libgit2 does not reject traversal components in a submodule path loaded from .gitmodules. The affected src/libgit2/submodule.c paths include git_submodule_lookup and git_submodule_add_setup. A crafted repository can specify a path such as ../escape-target, and applications that initialize the submodule can create directories outside the repository working tree. This issue is fixed in versions 1.8.6 and 1.9.5.

    Publication Mise à jour
  4. CVE-2026-5917

    Élevée · CVSS 8.6EPSS 1,43%Correctif disponible

    libgit2 Shell Command Injection via ssh_libssh2 Backend

    libgit2 versions before 1.8.7 and 1.9.0 before 1.9.7 built with the libssh2 SSH backend (USE_SSH=libssh2) contain a shell command injection vulnerability that allows remote attackers to execute arbitrary commands on an SSH server by supplying a repository path containing unescaped shell metacharacters such as single quotes, semicolons, or pipes. The gen_proto() function in ssh_libssh2.c inserts the repository path directly into a shell command string without escaping special characters before passing it to libssh2_channel_exec(), enabling an attacker to craft a malicious submodule URL in a .gitmodules file that, when processed during a recurs

    • Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm3
    Publication Mise à jour
  5. CVE-2024-24577

    Élevée · CVSS 8.6EPSS 1,55%Correctif disponible

    libgit2 is vulnerable to arbitrary code execution due to heap corruption in `git_index_add`

    libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_index_add` can cause heap corruption that could be leveraged for arbitrary code execution. There is an issue in the `has_dir_name` function in `src/libgit2/index.c`, which frees an entry that should not be freed. The freed entry is later used and overwritten with potentially bad actor-controlled data leading to controlled heap corruption. Depending on the application that uses libgit2, this could lead to arbitrary code execution. This issue

    • Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
    Publication Mise à jour
  6. CVE-2023-22742

    Moyenne · CVSS 5.3EPSS 0,58%Correctif disponible

    libgit2 fails to verify SSH keys by default

    libgit2 is a cross-platform, linkable library implementation of Git. When using an SSH remote with the optional libssh2 backend, libgit2 does not perform certificate checking by default. Prior versions of libgit2 require the caller to set the `certificate_check` field of libgit2's `git_remote_callbacks` structure - if a certificate check callback is not set, libgit2 does not perform any certificate checking. This means that by default - without configuring a certificate check callback, clients will not perform validation on the server SSH keys and may be subject to a man-in-the-middle attack. Users are encouraged to upgrade to v1.4.5 or v1.5.

    • Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
    Publication Mise à jour
  7. CVE-2020-12279

    Critique · CVSS 9.8EPSS 5,21%Correctif disponible

    CVE-2020-12279

    An issue was discovered in libgit2 before 0.28.4 and 0.9x before 0.99.0. checkout.c mishandles equivalent filenames that exist because of NTFS short names. This may allow remote code execution when cloning a repository. This issue is similar to CVE-2019-1353.

    • Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
    Publication Mise à jour
  8. CVE-2020-12278

    Critique · CVSS 9.8EPSS 5,24%Correctif disponible

    CVE-2020-12278

    An issue was discovered in libgit2 before 0.28.4 and 0.9x before 0.99.0. path.c mishandles equivalent filenames that exist because of NTFS Alternate Data Streams. This may allow remote code execution when cloning a repository. This issue is similar to CVE-2019-1352.

    • Mettez à jour vers 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →