CVE-2024-34750
CVE-2024-34750 · Apache Tomcat: HTTP/2 excess header handling DoS
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Improper Handling of Exceptional Conditions, Uncontrolled Resource Consumption vulnerability in Apache Tomcat. When processing an HTTP/2 stream, Tomcat did not handle some cases of excessive HTTP headers correctly. This led to a miscounting of active HTTP/2 streams which in turn led to the use of an incorrect infinite timeout which allowed connections to remain open which should have been closed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.0-M1 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25 or 9.0.90, which fixes the issue.
CVSS 7.5 · Élevée · EPSS 4,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
apache tomcat
- Versions du logiciel
- ≥ 11.0.0-M1, ≤ 11.0.0-M20: Concernée (semver)
- ≥ 10.1.0-M1, ≤ 10.1.24: Concernée (semver)
- ≥ 9.0.0-M1, ≤ 9.0.89: Concernée (semver)
- ≥ 8.5.0, ≤ 8.5.100: Concernée (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Inconnu (semver)
Aucun correctif publié
tomcat10 Debian:12
- Versions du logiciel
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Plages de versions concernées
- ECOSYSTEM: < 10.1.34-0+deb12u1
Mettez à jour vers 10.1.34-0+deb12u1
tomcat10 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 10.1.25-1
Mettez à jour vers 10.1.25-1
tomcat10 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 10.1.25-1
Mettez à jour vers 10.1.25-1
tomcat9 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- 9.0.16-3ubuntu0.18.04.2+esm7
- 9.0.16-3ubuntu0.18.04.2+esm8
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
tomcat9 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- 9.0.31-1ubuntu0.9+esm2
- 9.0.31-1ubuntu0.9+esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
tomcat9 Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- Plages de versions concernées
- ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm3
Mettez à jour vers 9.0.58-1ubuntu0.2+esm3
tomcat10 Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm2
Mettez à jour vers 10.1.16-1ubuntu0.1~esm2
tomcat9 Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Mettez à jour vers 9.0.70-2ubuntu0.1+esm2
tomcat9 Ubuntu:25.10
- Versions du logiciel
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2ubuntu3
Mettez à jour vers 9.0.70-2ubuntu3