CVE-2024-34750
CVE-2024-34750 · Apache Tomcat: HTTP/2 excess header handling DoS
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Improper Handling of Exceptional Conditions, Uncontrolled Resource Consumption vulnerability in Apache Tomcat. When processing an HTTP/2 stream, Tomcat did not handle some cases of excessive HTTP headers correctly. This led to a miscounting of active HTTP/2 streams which in turn led to the use of an incorrect infinite timeout which allowed connections to remain open which should have been closed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.0-M1 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25 or 9.0.90, which fixes the issue.
CVSS 7.5 · Hoch · EPSS 4,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
apache tomcat
- Softwareversionen
- ≥ 11.0.0-M1, ≤ 11.0.0-M20: Betroffen (semver)
- ≥ 10.1.0-M1, ≤ 10.1.24: Betroffen (semver)
- ≥ 9.0.0-M1, ≤ 9.0.89: Betroffen (semver)
- ≥ 8.5.0, ≤ 8.5.100: Betroffen (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Unbekannt (semver)
Keine Korrektur veröffentlicht
tomcat10 Debian:12
- Softwareversionen
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 10.1.34-0+deb12u1
Auf 10.1.34-0+deb12u1 aktualisieren
tomcat10 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 10.1.25-1
Auf 10.1.25-1 aktualisieren
tomcat10 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 10.1.25-1
Auf 10.1.25-1 aktualisieren
tomcat9 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.70-2
Auf 9.0.70-2 aktualisieren
tomcat9 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.70-2
Auf 9.0.70-2 aktualisieren
tomcat9 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.70-2
Auf 9.0.70-2 aktualisieren
tomcat9 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- 9.0.16-3ubuntu0.18.04.2+esm7
- 9.0.16-3ubuntu0.18.04.2+esm8
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
tomcat9 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- 9.0.31-1ubuntu0.9+esm2
- 9.0.31-1ubuntu0.9+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
tomcat9 Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm3
Auf 9.0.58-1ubuntu0.2+esm3 aktualisieren
tomcat10 Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm2
Auf 10.1.16-1ubuntu0.1~esm2 aktualisieren
tomcat9 Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Auf 9.0.70-2ubuntu0.1+esm2 aktualisieren
tomcat9 Ubuntu:25.10
- Softwareversionen
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.70-2ubuntu3
Auf 9.0.70-2ubuntu3 aktualisieren