CVE-2024-35228
CVE-2024-35228 · Improper Handling of Insufficient Permissions in Wagtail
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Wagtail is an open source content management system built on Django. Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`.
CVSS 5.5 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
wagtail
- Versions du logiciel
- >= 6.0.0, < 6.0.5: Concernée
- >= 6.1.0, < 6.1.2: Concernée
Aucun correctif publié
wagtail PyPI
- Versions du logiciel
- 6.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- Plages de versions concernées
- ECOSYSTEM: ≥ 6.0.0, < 6.0.5
Mettez à jour vers 6.0.5
wagtail PyPI
- Versions du logiciel
- 6.1
- 6.1.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 6.1.0, < 6.1.2
Mettez à jour vers 6.1.2
wagtail PyPI
- Versions du logiciel
- 6.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- 6.1
- 6.1.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 6.0.0, < 6.0.5 ∪ ≥ 6.1.0, < 6.1.2
Mettez à jour vers 6.0.5; Mettez à jour vers 6.1.2