p PatchFirst

CVE-2024-35228

CVE-2024-35228 · Improper Handling of Insufficient Permissions in Wagtail

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Wagtail is an open source content management system built on Django. Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`.

CVSS 5.5 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • wagtail

    Softwareversionen
    • >= 6.0.0, < 6.0.5: Betroffen
    • >= 6.1.0, < 6.1.2: Betroffen

    Keine Korrektur veröffentlicht

  • wagtail PyPI

    Softwareversionen
    • 6.0
    • 6.0.1
    • 6.0.2
    • 6.0.3
    • 6.0.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 6.0.0, < 6.0.5

    Auf 6.0.5 aktualisieren

  • wagtail PyPI

    Softwareversionen
    • 6.1
    • 6.1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 6.1.0, < 6.1.2

    Auf 6.1.2 aktualisieren

  • wagtail PyPI

    Softwareversionen
    • 6.0
    • 6.0.1
    • 6.0.2
    • 6.0.3
    • 6.0.4
    • 6.1
    • 6.1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 6.0.0, < 6.0.5 ∪ ≥ 6.1.0, < 6.1.2

    Auf 6.0.5 aktualisieren; Auf 6.1.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →