CVE-2024-38286
CVE-2024-38286 · Apache Tomcat: Denial of Service
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.
CVSS 8.6 · Élevée · EPSS 1,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
apache tomcat
- Versions du logiciel
- ≥ 11.0.0-M1, ≤ 11.0.0-M20: Concernée (semver)
- ≥ 10.1.0-M1, ≤ 10.1.24: Concernée (semver)
- ≥ 9.0.13, ≤ 9.0.89: Concernée (semver)
- ≥ 8.5.35, ≤ 8.5.100: Concernée (semver)
- ≥ 7.0.92, ≤ 7.0.109: Concernée (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Inconnu (semver)
Aucun correctif publié
tomcat10 Debian:12
- Versions du logiciel
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Plages de versions concernées
- ECOSYSTEM: < 10.1.34-0+deb12u1
Mettez à jour vers 10.1.34-0+deb12u1
tomcat10 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 10.1.25-1
Mettez à jour vers 10.1.25-1
tomcat10 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 10.1.25-1
Mettez à jour vers 10.1.25-1
tomcat9 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat8 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- 8.5.39-1ubuntu1~18.04.3+esm5
- 8.5.39-1ubuntu1~18.04.3+esm6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
tomcat9 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- Plages de versions concernées
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm7
Mettez à jour vers 9.0.16-3ubuntu0.18.04.2+esm7
tomcat9 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- Plages de versions concernées
- ECOSYSTEM: < 9.0.31-1ubuntu0.9+esm2
Mettez à jour vers 9.0.31-1ubuntu0.9+esm2
tomcat9 Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- Plages de versions concernées
- ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm3
Mettez à jour vers 9.0.58-1ubuntu0.2+esm3
tomcat10 Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm2
Mettez à jour vers 10.1.16-1ubuntu0.1~esm2
tomcat9 Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Mettez à jour vers 9.0.70-2ubuntu0.1+esm2
tomcat9 Ubuntu:25.10
- Versions du logiciel
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2ubuntu3
Mettez à jour vers 9.0.70-2ubuntu3