CVE-2024-38286
CVE-2024-38286 · Apache Tomcat: Denial of Service
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.
CVSS 8.6 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- ≥ 11.0.0-M1, ≤ 11.0.0-M20: Affected (semver)
- ≥ 10.1.0-M1, ≤ 10.1.24: Affected (semver)
- ≥ 9.0.13, ≤ 9.0.89: Affected (semver)
- ≥ 8.5.35, ≤ 8.5.100: Affected (semver)
- ≥ 7.0.92, ≤ 7.0.109: Affected (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Unknown (semver)
No fix published
tomcat10 Debian:12
- Versions
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Affected ranges
- ECOSYSTEM: < 10.1.34-0+deb12u1
Update to 10.1.34-0+deb12u1
tomcat10 Debian:13
- Affected ranges
- ECOSYSTEM: < 10.1.25-1
Update to 10.1.25-1
tomcat10 Debian:14
- Affected ranges
- ECOSYSTEM: < 10.1.25-1
Update to 10.1.25-1
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.70-2
Update to 9.0.70-2
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.70-2
Update to 9.0.70-2
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.70-2
Update to 9.0.70-2
tomcat8 Ubuntu:Pro:18.04:LTS
- Versions
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- 8.5.39-1ubuntu1~18.04.3+esm5
- 8.5.39-1ubuntu1~18.04.3+esm6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat9 Ubuntu:Pro:18.04:LTS
- Versions
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- Affected ranges
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm7
Update to 9.0.16-3ubuntu0.18.04.2+esm7
tomcat9 Ubuntu:Pro:20.04:LTS
- Versions
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- Affected ranges
- ECOSYSTEM: < 9.0.31-1ubuntu0.9+esm2
Update to 9.0.31-1ubuntu0.9+esm2
tomcat9 Ubuntu:Pro:22.04:LTS
- Versions
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- Affected ranges
- ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm3
Update to 9.0.58-1ubuntu0.2+esm3
tomcat10 Ubuntu:Pro:24.04:LTS
- Versions
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm2
Update to 10.1.16-1ubuntu0.1~esm2
tomcat9 Ubuntu:Pro:24.04:LTS
- Versions
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Update to 9.0.70-2ubuntu0.1+esm2
tomcat9 Ubuntu:25.10
- Versions
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Affected ranges
- ECOSYSTEM: < 9.0.70-2ubuntu3
Update to 9.0.70-2ubuntu3