CVE-2024-41110
CVE-2024-41110 · Moby authz zero length regression
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Moby is an open-source project created by Docker for software containerization. A security vulnerability has been detected in certain versions of Docker Engine, which could allow an attacker to bypass authorization plugins (AuthZ) under specific circumstances. The base likelihood of this being exploited is low. Using a specially-crafted API request, an Engine API client could make the daemon forward the request or response to an authorization plugin without the body. In certain circumstances, the authorization plugin may allow a request which it would have otherwise denied if the body had been forwarded to it. A security issue was discovered In 2018, where an attacker could bypass AuthZ plugins using a specially crafted API request. This could lead to unauthorized actions, including privilege escalation. Although this issue was fixed in Docker Engine v18.09.1 in January 2019, the fix was not carried forward to later major versions, resulting in a regression. Anyone who depends on authorization plugins that introspect the request and/or response body to make access control decisions is potentially impacted. Docker EE v19.03.x and all versions of Mirantis Container Runtime are not vulnerable. docker-ce v27.1.1 containes patches to fix the vulnerability. Patches have also been merged into the master, 19.03, 20.0, 23.0, 24.0, 25.0, 26.0, and 26.1 release branches. If one is unable to upgrade immediately, avoid using AuthZ plugins and/or restrict access to the Docker API to trusted parties, following the principle of least privilege.
CVSS 10.0 · Critique · EPSS 16,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · containers
Produits et versions concernés
docker engine
- Versions du logiciel
- >= 19.03.0, <= 19.03.15: Concernée
- >= 20.0.0, <= 20.10.27: Concernée
- >= 23.0.0, <= 23.0.14: Concernée
- >= 24.0.0, <= 24.0.9: Concernée
- >= 25.0.0, <= 25.0.5: Concernée
- >= 26.0.0, <= 26.0.2: Concernée
- >= 26.1.0, <= 26.1.14: Concernée
- >= 27.0.0, <= 27.0.3: Concernée
- = 27.1.0: Concernée
Aucun correctif publié
docker.io Debian:12
- Versions du logiciel
- 20.10.24+dfsg1-1
- Plages de versions concernées
- ECOSYSTEM: < 20.10.24+dfsg1-1+deb12u1
Mettez à jour vers 20.10.24+dfsg1-1+deb12u1
docker.io Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 26.1.5+dfsg1-2
Mettez à jour vers 26.1.5+dfsg1-2
docker.io Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 26.1.5+dfsg1-2
Mettez à jour vers 26.1.5+dfsg1-2
docker.io Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.13.1-0ubuntu6
- 17.03.2-0ubuntu1
- 17.03.2-0ubuntu3
- 17.03.2-0ubuntu5
- 17.12.1-0ubuntu1
- 18.06.1-0ubuntu1~18.04.1
- 18.06.1-0ubuntu1.2~18.04.1
- 18.09.2-0ubuntu1~18.04.1
- 18.09.5-0ubuntu1~18.04.2
- 18.09.7-0ubuntu1~18.04.1
- 18.09.7-0ubuntu1~18.04.3
- 18.09.7-0ubuntu1~18.04.4
- 19.03.6-0ubuntu1~18.04.1
- 19.03.6-0ubuntu1~18.04.2
- 19.03.6-0ubuntu1~18.04.3
- 20.10.2-0ubuntu1~18.04.2
- 20.10.2-0ubuntu1~18.04.3
- 20.10.7-0ubuntu1~18.04.1
- 20.10.7-0ubuntu1~18.04.2
- 20.10.7-0ubuntu5~18.04.2
- 20.10.7-0ubuntu5~18.04.3
- 20.10.12-0ubuntu2~18.04.1
- 20.10.21-0ubuntu1~18.04.2
- 20.10.21-0ubuntu1~18.04.3
- Plages de versions concernées
- ECOSYSTEM: < 20.10.21-0ubuntu1~18.04.3+esm1
Mettez à jour vers 20.10.21-0ubuntu1~18.04.3+esm1
docker.io Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 19.03.2-0ubuntu1
- 19.03.6-0ubuntu1
- 19.03.8-0ubuntu1
- 19.03.8-0ubuntu1.20.04
- 19.03.8-0ubuntu1.20.04.1
- 19.03.8-0ubuntu1.20.04.2
- 20.10.2-0ubuntu1~20.04.2
- 20.10.2-0ubuntu1~20.04.3
- 20.10.7-0ubuntu1~20.04.1
- 20.10.7-0ubuntu1~20.04.2
- 20.10.7-0ubuntu5~20.04.1
- 20.10.7-0ubuntu5~20.04.2
- 20.10.12-0ubuntu2~20.04.1
- 20.10.21-0ubuntu1~20.04.1
- 20.10.21-0ubuntu1~20.04.2
- 20.10.21-0ubuntu1~20.04.4
- 20.10.21-0ubuntu1~20.04.5
- 20.10.21-0ubuntu1~20.04.6
- Plages de versions concernées
- ECOSYSTEM: < 20.10.21-0ubuntu1~20.04.6+esm1
Mettez à jour vers 20.10.21-0ubuntu1~20.04.6+esm1
docker.io-app Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 20.10.25-0ubuntu1~20.04.1
- 20.10.25-0ubuntu1~20.04.2
- 24.0.5-0ubuntu1~20.04.1
- 24.0.7-0ubuntu2~20.04.1
- 26.1.3-0ubuntu1~20.04.1
- Plages de versions concernées
- ECOSYSTEM: < 26.1.3-0ubuntu1~20.04.1+esm1
Mettez à jour vers 26.1.3-0ubuntu1~20.04.1+esm1
docker.io-app Ubuntu:22.04:LTS
- Versions du logiciel
- 20.10.25-0ubuntu1~22.04.1
- 20.10.25-0ubuntu1~22.04.2
- 24.0.5-0ubuntu1~22.04.1
- 24.0.7-0ubuntu2~22.04.1
- 26.1.3-0ubuntu1~22.04.1
- 27.5.1-0ubuntu3~22.04.1
- Plages de versions concernées
- ECOSYSTEM: < 27.5.1-0ubuntu3~22.04.2
Mettez à jour vers 27.5.1-0ubuntu3~22.04.2
docker.io Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 20.10.7-0ubuntu5
- 20.10.7-0ubuntu7
- 20.10.12-0ubuntu1
- 20.10.12-0ubuntu2
- 20.10.12-0ubuntu3
- 20.10.12-0ubuntu3+gke1.24.1
- 20.10.12-0ubuntu4
- 20.10.21-0ubuntu1~22.04.2
- 20.10.21-0ubuntu1~22.04.3
- 20.10.21-0ubuntu1~22.04.5
- 20.10.21-0ubuntu1~22.04.6
- 20.10.21-0ubuntu1~22.04.7
- Plages de versions concernées
- ECOSYSTEM: < 20.10.21-0ubuntu1~22.04.7+esm1
Mettez à jour vers 20.10.21-0ubuntu1~22.04.7+esm1
docker.io-app Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 20.10.25-0ubuntu1~22.04.1
- 20.10.25-0ubuntu1~22.04.2
- 24.0.5-0ubuntu1~22.04.1
- 24.0.7-0ubuntu2~22.04.1
- 26.1.3-0ubuntu1~22.04.1
- Plages de versions concernées
- ECOSYSTEM: < 26.1.3-0ubuntu1~22.04.1+esm1
Mettez à jour vers 26.1.3-0ubuntu1~22.04.1+esm1
docker.io-app Ubuntu:24.04:LTS
- Versions du logiciel
- 24.0.5-0ubuntu1
- 24.0.7-0ubuntu1
- 24.0.7-0ubuntu2
- 24.0.7-0ubuntu3
- 24.0.7-0ubuntu4
- 24.0.7-0ubuntu4.1
- 26.1.3-0ubuntu1~24.04.1
- 27.5.1-0ubuntu3~24.04.1
- Plages de versions concernées
- ECOSYSTEM: < 27.5.1-0ubuntu3~24.04.2
Mettez à jour vers 27.5.1-0ubuntu3~24.04.2
docker.io Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 20.10.24+dfsg1-1ubuntu2
- 20.10.25+dfsg1-2ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 20.10.25+dfsg1-2ubuntu1+esm1
Mettez à jour vers 20.10.25+dfsg1-2ubuntu1+esm1
docker.io-app Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 24.0.5-0ubuntu1
- 24.0.7-0ubuntu1
- 24.0.7-0ubuntu2
- 24.0.7-0ubuntu3
- 24.0.7-0ubuntu4
- 24.0.7-0ubuntu4.1
- 26.1.3-0ubuntu1~24.04.1
- Plages de versions concernées
- ECOSYSTEM: < 26.1.3-0ubuntu1~24.04.1+esm1
Mettez à jour vers 26.1.3-0ubuntu1~24.04.1+esm1
Sources originales
- https://github.com/moby/moby/security/advisories/GHSA-v23v-6jw2-98fq
- https://github.com/moby/moby/commit/411e817ddf710ff8e08fa193da80cb78af708191
- https://github.com/moby/moby/commit/42f40b1d6dd7562342f832b9cd2adf9e668eeb76
- https://github.com/moby/moby/commit/65cc597cea28cdc25bea3b8a86384b4251872919
- https://github.com/moby/moby/commit/852759a7df454cbf88db4e954c919becd48faa9b
- https://github.com/moby/moby/commit/a31260625655cff9ae226b51757915e275e304b0
- https://github.com/moby/moby/commit/a79fabbfe84117696a19671f4aa88b82d0f64fc1
- https://github.com/moby/moby/commit/ae160b4edddb72ef4bd71f66b975a1a1cc434f00
- https://github.com/moby/moby/commit/ae2b3666c517c96cbc2adf1af5591a6b00d4ec0f
- https://github.com/moby/moby/commit/cc13f952511154a2866bddbb7dddebfe9e83b801
- https://github.com/moby/moby/commit/fc274cd2ff4cf3b48c91697fb327dd1fb95588fb
- https://www.docker.com/blog/docker-security-advisory-docker-engine-authz-plugin
- https://security.netapp.com/advisory/ntap-20240802-0001/
- https://lists.debian.org/debian-lts-announce/2024/10/msg00009.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-41110