p PatchFirst

CVE-2024-41110

CVE-2024-41110 · Moby authz zero length regression

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Moby is an open-source project created by Docker for software containerization. A security vulnerability has been detected in certain versions of Docker Engine, which could allow an attacker to bypass authorization plugins (AuthZ) under specific circumstances. The base likelihood of this being exploited is low. Using a specially-crafted API request, an Engine API client could make the daemon forward the request or response to an authorization plugin without the body. In certain circumstances, the authorization plugin may allow a request which it would have otherwise denied if the body had been forwarded to it. A security issue was discovered In 2018, where an attacker could bypass AuthZ plugins using a specially crafted API request. This could lead to unauthorized actions, including privilege escalation. Although this issue was fixed in Docker Engine v18.09.1 in January 2019, the fix was not carried forward to later major versions, resulting in a regression. Anyone who depends on authorization plugins that introspect the request and/or response body to make access control decisions is potentially impacted. Docker EE v19.03.x and all versions of Mirantis Container Runtime are not vulnerable. docker-ce v27.1.1 containes patches to fix the vulnerability. Patches have also been merged into the master, 19.03, 20.0, 23.0, 24.0, 25.0, 26.0, and 26.1 release branches. If one is unable to upgrade immediately, avoid using AuthZ plugins and/or restrict access to the Docker API to trusted parties, following the principle of least privilege.

CVSS 10.0 · Kritisch · EPSS 16,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · containers

Betroffene Produkte und Versionen

  • docker engine

    Softwareversionen
    • >= 19.03.0, <= 19.03.15: Betroffen
    • >= 20.0.0, <= 20.10.27: Betroffen
    • >= 23.0.0, <= 23.0.14: Betroffen
    • >= 24.0.0, <= 24.0.9: Betroffen
    • >= 25.0.0, <= 25.0.5: Betroffen
    • >= 26.0.0, <= 26.0.2: Betroffen
    • >= 26.1.0, <= 26.1.14: Betroffen
    • >= 27.0.0, <= 27.0.3: Betroffen
    • = 27.1.0: Betroffen

    Keine Korrektur veröffentlicht

  • docker.io Debian:12

    Softwareversionen
    • 20.10.24+dfsg1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.24+dfsg1-1+deb12u1

    Auf 20.10.24+dfsg1-1+deb12u1 aktualisieren

  • docker.io Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 26.1.5+dfsg1-2

    Auf 26.1.5+dfsg1-2 aktualisieren

  • docker.io Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 26.1.5+dfsg1-2

    Auf 26.1.5+dfsg1-2 aktualisieren

  • docker.io Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.13.1-0ubuntu6
    • 17.03.2-0ubuntu1
    • 17.03.2-0ubuntu3
    • 17.03.2-0ubuntu5
    • 17.12.1-0ubuntu1
    • 18.06.1-0ubuntu1~18.04.1
    • 18.06.1-0ubuntu1.2~18.04.1
    • 18.09.2-0ubuntu1~18.04.1
    • 18.09.5-0ubuntu1~18.04.2
    • 18.09.7-0ubuntu1~18.04.1
    • 18.09.7-0ubuntu1~18.04.3
    • 18.09.7-0ubuntu1~18.04.4
    • 19.03.6-0ubuntu1~18.04.1
    • 19.03.6-0ubuntu1~18.04.2
    • 19.03.6-0ubuntu1~18.04.3
    • 20.10.2-0ubuntu1~18.04.2
    • 20.10.2-0ubuntu1~18.04.3
    • 20.10.7-0ubuntu1~18.04.1
    • 20.10.7-0ubuntu1~18.04.2
    • 20.10.7-0ubuntu5~18.04.2
    • 20.10.7-0ubuntu5~18.04.3
    • 20.10.12-0ubuntu2~18.04.1
    • 20.10.21-0ubuntu1~18.04.2
    • 20.10.21-0ubuntu1~18.04.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.21-0ubuntu1~18.04.3+esm1

    Auf 20.10.21-0ubuntu1~18.04.3+esm1 aktualisieren

  • docker.io Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 19.03.2-0ubuntu1
    • 19.03.6-0ubuntu1
    • 19.03.8-0ubuntu1
    • 19.03.8-0ubuntu1.20.04
    • 19.03.8-0ubuntu1.20.04.1
    • 19.03.8-0ubuntu1.20.04.2
    • 20.10.2-0ubuntu1~20.04.2
    • 20.10.2-0ubuntu1~20.04.3
    • 20.10.7-0ubuntu1~20.04.1
    • 20.10.7-0ubuntu1~20.04.2
    • 20.10.7-0ubuntu5~20.04.1
    • 20.10.7-0ubuntu5~20.04.2
    • 20.10.12-0ubuntu2~20.04.1
    • 20.10.21-0ubuntu1~20.04.1
    • 20.10.21-0ubuntu1~20.04.2
    • 20.10.21-0ubuntu1~20.04.4
    • 20.10.21-0ubuntu1~20.04.5
    • 20.10.21-0ubuntu1~20.04.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.21-0ubuntu1~20.04.6+esm1

    Auf 20.10.21-0ubuntu1~20.04.6+esm1 aktualisieren

  • docker.io-app Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 20.10.25-0ubuntu1~20.04.1
    • 20.10.25-0ubuntu1~20.04.2
    • 24.0.5-0ubuntu1~20.04.1
    • 24.0.7-0ubuntu2~20.04.1
    • 26.1.3-0ubuntu1~20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 26.1.3-0ubuntu1~20.04.1+esm1

    Auf 26.1.3-0ubuntu1~20.04.1+esm1 aktualisieren

  • docker.io-app Ubuntu:22.04:LTS

    Softwareversionen
    • 20.10.25-0ubuntu1~22.04.1
    • 20.10.25-0ubuntu1~22.04.2
    • 24.0.5-0ubuntu1~22.04.1
    • 24.0.7-0ubuntu2~22.04.1
    • 26.1.3-0ubuntu1~22.04.1
    • 27.5.1-0ubuntu3~22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 27.5.1-0ubuntu3~22.04.2

    Auf 27.5.1-0ubuntu3~22.04.2 aktualisieren

  • docker.io Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 20.10.7-0ubuntu5
    • 20.10.7-0ubuntu7
    • 20.10.12-0ubuntu1
    • 20.10.12-0ubuntu2
    • 20.10.12-0ubuntu3
    • 20.10.12-0ubuntu3+gke1.24.1
    • 20.10.12-0ubuntu4
    • 20.10.21-0ubuntu1~22.04.2
    • 20.10.21-0ubuntu1~22.04.3
    • 20.10.21-0ubuntu1~22.04.5
    • 20.10.21-0ubuntu1~22.04.6
    • 20.10.21-0ubuntu1~22.04.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.21-0ubuntu1~22.04.7+esm1

    Auf 20.10.21-0ubuntu1~22.04.7+esm1 aktualisieren

  • docker.io-app Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 20.10.25-0ubuntu1~22.04.1
    • 20.10.25-0ubuntu1~22.04.2
    • 24.0.5-0ubuntu1~22.04.1
    • 24.0.7-0ubuntu2~22.04.1
    • 26.1.3-0ubuntu1~22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 26.1.3-0ubuntu1~22.04.1+esm1

    Auf 26.1.3-0ubuntu1~22.04.1+esm1 aktualisieren

  • docker.io-app Ubuntu:24.04:LTS

    Softwareversionen
    • 24.0.5-0ubuntu1
    • 24.0.7-0ubuntu1
    • 24.0.7-0ubuntu2
    • 24.0.7-0ubuntu3
    • 24.0.7-0ubuntu4
    • 24.0.7-0ubuntu4.1
    • 26.1.3-0ubuntu1~24.04.1
    • 27.5.1-0ubuntu3~24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 27.5.1-0ubuntu3~24.04.2

    Auf 27.5.1-0ubuntu3~24.04.2 aktualisieren

  • docker.io Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 20.10.24+dfsg1-1ubuntu2
    • 20.10.25+dfsg1-2ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.25+dfsg1-2ubuntu1+esm1

    Auf 20.10.25+dfsg1-2ubuntu1+esm1 aktualisieren

  • docker.io-app Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 24.0.5-0ubuntu1
    • 24.0.7-0ubuntu1
    • 24.0.7-0ubuntu2
    • 24.0.7-0ubuntu3
    • 24.0.7-0ubuntu4
    • 24.0.7-0ubuntu4.1
    • 26.1.3-0ubuntu1~24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 26.1.3-0ubuntu1~24.04.1+esm1

    Auf 26.1.3-0ubuntu1~24.04.1+esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →