p PatchFirst

CVE-2025-2175

CVE-2025-2175 · libzvbi _vbi_strndup_iconv integer overflow

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

CVSS 5.3 · Moyenne · EPSS 0,6% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • libzvbi

    Versions du logiciel
    • 0.2.0: Concernée
    • 0.2.1: Concernée
    • 0.2.2: Concernée
    • 0.2.3: Concernée
    • 0.2.4: Concernée
    • 0.2.5: Concernée
    • 0.2.6: Concernée
    • 0.2.7: Concernée
    • 0.2.8: Concernée
    • 0.2.9: Concernée
    • 0.2.10: Concernée
    • 0.2.11: Concernée
    • 0.2.12: Concernée
    • 0.2.13: Concernée
    • 0.2.14: Concernée
    • 0.2.15: Concernée
    • 0.2.16: Concernée
    • 0.2.17: Concernée
    • 0.2.18: Concernée
    • 0.2.19: Concernée
    • 0.2.20: Concernée
    • 0.2.21: Concernée
    • 0.2.22: Concernée
    • 0.2.23: Concernée
    • 0.2.24: Concernée
    • 0.2.25: Concernée
    • 0.2.26: Concernée
    • 0.2.27: Concernée
    • 0.2.28: Concernée
    • 0.2.29: Concernée
    • 0.2.30: Concernée
    • 0.2.31: Concernée
    • 0.2.32: Concernée
    • 0.2.33: Concernée
    • 0.2.34: Concernée
    • 0.2.35: Concernée
    • 0.2.36: Concernée
    • 0.2.37: Concernée
    • 0.2.38: Concernée
    • 0.2.39: Concernée
    • 0.2.40: Concernée
    • 0.2.41: Concernée
    • 0.2.42: Concernée
    • 0.2.43: Concernée

    Aucun correctif publié

  • zvbi Debian:12

    Versions du logiciel
    • 0.2.41-1
    Plages de versions concernées
    • ECOSYSTEM: < 0.2.41-1+deb12u1

    Mettez à jour vers 0.2.41-1+deb12u1

  • zvbi Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 0.2.44-1

    Mettez à jour vers 0.2.44-1

  • zvbi Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 0.2.44-1

    Mettez à jour vers 0.2.44-1

  • zvbi Ubuntu:14.04:LTS

    Versions du logiciel
    • 0.2.33-7
    • 0.2.35-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • zvbi Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 0.2.35-9
    • 0.2.35-10
    Plages de versions concernées
    • ECOSYSTEM: < 0.2.35-10ubuntu0.1~esm1

    Mettez à jour vers 0.2.35-10ubuntu0.1~esm1

  • zvbi Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 0.2.35-13
    Plages de versions concernées
    • ECOSYSTEM: < 0.2.35-13ubuntu0.1~esm1

    Mettez à jour vers 0.2.35-13ubuntu0.1~esm1

  • zvbi Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 0.2.35-16
    • 0.2.35-17
    Plages de versions concernées
    • ECOSYSTEM: < 0.2.35-17ubuntu0.1~esm1

    Mettez à jour vers 0.2.35-17ubuntu0.1~esm1

  • zvbi Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 0.2.35-18
    • 0.2.35-19
    Plages de versions concernées
    • ECOSYSTEM: < 0.2.35-19ubuntu0.1~esm1

    Mettez à jour vers 0.2.35-19ubuntu0.1~esm1

  • zvbi Ubuntu:Pro:24.04:LTS

    Versions du logiciel
    • 0.2.41-2
    • 0.2.42-1
    • 0.2.42-1.1
    • 0.2.42-1.2
    • 0.2.42-2
    Plages de versions concernées
    • ECOSYSTEM: < 0.2.42-2ubuntu0.24.04.1~esm1

    Mettez à jour vers 0.2.42-2ubuntu0.24.04.1~esm1

Sources originales

Vérifiez votre serveur →