p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de zvbi

Vulnérabilités publiées pour zvbi au cours des 30 derniers jours : 1. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 7

  1. CVE-2026-110654

    Moyenne · CVSS 6.9EPSS 0,17%Aucun correctif publié

    libzvbi through 0.2.45 Out-of-Bounds Write via Teletext DRCS convert_drcs

    libzvbi through 0.2.45 contains an out-of-bounds write vulnerability in the Teletext decoder that allows attackers to corrupt memory by supplying unvalidated DRCS pixel-mode values in X/28/3 packets. Attackers can send a crafted Teletext stream decoded via vbi_decode with every slot set to DRCS_MODE_6_5_4, causing convert_drcs to overflow chars[48][60] and crash the application.

    Publication Mise à jour
  2. CVE-2025-2177

    Moyenne · CVSS 6.9EPSS 0,65%Correctif disponible

    libzvbi search.c vbi_search_new integer overflow

    A vulnerability classified as critical was found in libzvbi up to 0.2.43. This vulnerability affects the function vbi_search_new of the file src/search.c. The manipulation of the argument pat_len leads to integer overflow. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

    • Mettez à jour vers 0.2.41-1+deb12u1
    Publication Mise à jour
  3. CVE-2025-2176

    Moyenne · CVSS 6.9EPSS 0,67%Correctif disponible

    libzvbi io-sim.c vbi_capture_sim_load_caption integer overflow

    A vulnerability classified as critical has been found in libzvbi up to 0.2.43. This affects the function vbi_capture_sim_load_caption of the file src/io-sim.c. The manipulation leads to integer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The identifier of the patch is ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

    • Mettez à jour vers 0.2.41-1+deb12u1
    Publication Mise à jour
  4. CVE-2025-2175

    Moyenne · CVSS 5.3EPSS 0,62%Correctif disponible

    libzvbi _vbi_strndup_iconv integer overflow

    A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

    • Mettez à jour vers 0.2.41-1+deb12u1
    Publication Mise à jour
  5. CVE-2025-2174

    Moyenne · CVSS 6.9EPSS 0,83%Correctif disponible

    libzvbi conv.c vbi_strndup_iconv_ucs2 integer overflow

    A vulnerability was found in libzvbi up to 0.2.43. It has been declared as problematic. Affected by this vulnerability is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to integer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is named ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

    • Mettez à jour vers 0.2.41-1+deb12u1
    Publication Mise à jour
  6. CVE-2025-2173

    Moyenne · CVSS 6.9EPSS 0,61%Correctif disponible

    libzvbi conv.c vbi_strndup_iconv_ucs2 uninitialized pointer

    A vulnerability was found in libzvbi up to 0.2.43. It has been classified as problematic. Affected is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to uninitialized pointer. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as 8def647eea27f7fd7ad33ff79c2d6d3e39948dce. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

    • Mettez à jour vers 0.2.41-1+deb12u1
    Publication Mise à jour
  7. CVE-2007-3121

    Non évaluéeEPSS 2,2%Correctif disponible

    CVE-2007-3121

    Buffer overflow in the CCdecode function in contrib/ntsc-cc.c in the zvbi-ntsc-cc tool in Zapping VBI Library (ZVBI) before 0.2.25 allows attackers to cause a denial of service (application crash) and possibly execute arbitrary code via long data during a reception error. NOTE: some of these details are obtained from third party information.

    • Mettez à jour vers 0.2.25-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →