CVE-2025-26619
CVE-2025-26619 · Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
CVSS 5.3 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
vega
- Versions du logiciel
- < 5.31.0: Concernée
Aucun correctif publié
vega.js Debian:12
- Versions du logiciel
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vega.js Debian:13
- Versions du logiciel
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vega.js Debian:14
- Versions du logiciel
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- Plages de versions concernées
- ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-1
Mettez à jour vers 5.33.1+ds+~cs5.3.0-1
vega npm
- Plages de versions concernées
- SEMVER: < 5.31.0
Mettez à jour vers 5.31.0
vega-functions npm
- Plages de versions concernées
- SEMVER: < 5.16.0
Mettez à jour vers 5.16.0
vega.js Ubuntu:24.04:LTS
- Versions du logiciel
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vega.js Ubuntu:25.10
- Versions du logiciel
- 5.28.0+ds+~cs5.3.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vega.js Ubuntu:26.10
- Versions du logiciel
- 5.28.0+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vega.js Ubuntu:26.04:LTS
- Versions du logiciel
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié