p PatchFirst

CVE-2025-26619

CVE-2025-26619 · Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.

CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • vega

    Softwareversionen
    • < 5.31.0: Betroffen

    Keine Korrektur veröffentlicht

  • vega.js Debian:12

    Softwareversionen
    • 5.22.1+ds+~3.1.0-4
    • 5.25.0+ds+~cs5.3.0-1
    • 5.25.0+ds+~cs5.3.0-2
    • 5.25.0+ds+~cs5.3.0-3
    • 5.25.0+ds+~cs5.3.0-4
    • 5.25.0+ds+~cs5.3.0-5
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    • 5.28.0+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-1
    • 5.33.1+ds+~cs5.3.0-2
    • 5.33.1+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • vega.js Debian:13

    Softwareversionen
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    • 5.28.0+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-1
    • 5.33.1+ds+~cs5.3.0-2
    • 5.33.1+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • vega.js Debian:14

    Softwareversionen
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    • 5.28.0+ds+~cs5.3.0-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-1

    Auf 5.33.1+ds+~cs5.3.0-1 aktualisieren

  • vega npm

    Betroffene Versionsbereiche
    • SEMVER: < 5.31.0

    Auf 5.31.0 aktualisieren

  • vega-functions npm

    Betroffene Versionsbereiche
    • SEMVER: < 5.16.0

    Auf 5.16.0 aktualisieren

  • vega.js Ubuntu:24.04:LTS

    Softwareversionen
    • 5.25.0+ds+~cs5.3.0-2
    • 5.25.0+ds+~cs5.3.0-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • vega.js Ubuntu:25.10

    Softwareversionen
    • 5.28.0+ds+~cs5.3.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • vega.js Ubuntu:26.10

    Softwareversionen
    • 5.28.0+ds+~cs5.3.0-2
    • 5.33.1+ds+~cs5.3.0-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • vega.js Ubuntu:26.04:LTS

    Softwareversionen
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →