CVE-2025-31650
CVE-2025-31650 · Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
CVSS 7.5 · Élevée · EPSS 61,3% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
apache tomcat
- Versions du logiciel
- ≥ 9.0.76, ≤ 9.0.102: Concernée (semver)
- ≥ 10.1.10, ≤ 10.1.39: Concernée (semver)
- ≥ 11.0.0-M2, ≤ 11.0.5: Concernée (semver)
- ≥ 8.5.90, ≤ 8.5.100: Concernée (semver)
Aucun correctif publié
tomcat10 Debian:12
- Versions du logiciel
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.34-0+deb12u1
- 10.1.34-0+deb12u2
- 10.1.34-1
- 10.1.35-1
- 10.1.40-1~bpo12+1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Plages de versions concernées
- ECOSYSTEM: < 10.1.40-1
Mettez à jour vers 10.1.40-1
tomcat10 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 10.1.40-1
Mettez à jour vers 10.1.40-1
tomcat10 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 10.1.40-1
Mettez à jour vers 10.1.40-1
tomcat11 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 11.0.6-1
Mettez à jour vers 11.0.6-1
tomcat11 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 11.0.6-1
Mettez à jour vers 11.0.6-1
tomcat9 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat9 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 9.0.70-2
Mettez à jour vers 9.0.70-2
tomcat10 Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- 10.1.16-1ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm3
Mettez à jour vers 10.1.16-1ubuntu0.1~esm3