p PatchFirst

CVE-2025-31650

CVE-2025-31650 · Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

CVSS 7.5 · Hoch · EPSS 61,3% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache tomcat

    Softwareversionen
    • ≥ 9.0.76, ≤ 9.0.102: Betroffen (semver)
    • ≥ 10.1.10, ≤ 10.1.39: Betroffen (semver)
    • ≥ 11.0.0-M2, ≤ 11.0.5: Betroffen (semver)
    • ≥ 8.5.90, ≤ 8.5.100: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • tomcat10 Debian:12

    Softwareversionen
    • 10.1.10-1
    • 10.1.13-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.20-1
    • 10.1.23-1
    • 10.1.25-1
    • 10.1.25-1~bpo12+1
    • 10.1.25-2
    • 10.1.30-1
    • 10.1.30-1~bpo12+1
    • 10.1.31-1
    • 10.1.33-1
    • 10.1.33-1~bpo12+1
    • 10.1.34-0+deb12u1
    • 10.1.34-0+deb12u2
    • 10.1.34-1
    • 10.1.35-1
    • 10.1.40-1~bpo12+1
    • 10.1.6-1
    • 10.1.6-1+deb12u1
    • 10.1.6-1+deb12u2
    • 10.1.7-1
    • 10.1.8-1
    • 10.1.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 10.1.40-1

    Auf 10.1.40-1 aktualisieren

  • tomcat10 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 10.1.40-1

    Auf 10.1.40-1 aktualisieren

  • tomcat10 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 10.1.40-1

    Auf 10.1.40-1 aktualisieren

  • tomcat11 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 11.0.6-1

    Auf 11.0.6-1 aktualisieren

  • tomcat11 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 11.0.6-1

    Auf 11.0.6-1 aktualisieren

  • tomcat9 Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.0.70-2

    Auf 9.0.70-2 aktualisieren

  • tomcat9 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.0.70-2

    Auf 9.0.70-2 aktualisieren

  • tomcat9 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.0.70-2

    Auf 9.0.70-2 aktualisieren

  • tomcat10 Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 10.1.10-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.16-1ubuntu0.1~esm1
    • 10.1.16-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm3

    Auf 10.1.16-1ubuntu0.1~esm3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →