CVE-2025-48945
CVE-2025-48945 · pycares has a Use-After-Free Vulnerability
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
pycares is a Python module which provides an interface to c-ares. c-ares is a C library that performs DNS requests and name resolutions asynchronously. Prior to version 4.9.0, pycares is vulnerable to a use-after-free condition that occurs when a Channel object is garbage collected while DNS queries are still pending. This results in a fatal Python error and interpreter crash. The vulnerability has been fixed in pycares 4.9.0 by implementing a safe channel destruction mechanism.
CVSS 8.2 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
aiodns
- Versions du logiciel
- < 4.9.0: Concernée
Aucun correctif publié
pycares Debian:12
- Versions du logiciel
- 4.3.0-2
- 4.4.0-1
- 4.4.0-2
- 4.9.0-1
- 5.0.0-1
- 5.0.0-2
- 5.0.0-3
- 5.0.1-1
- 5.0.1-2
- 5.0.1-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Debian:13
- Versions du logiciel
- 4.4.0-2
- 4.9.0-1
- 5.0.0-1
- 5.0.0-2
- 5.0.0-3
- 5.0.1-1
- 5.0.1-2
- 5.0.1-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Debian:14
- Versions du logiciel
- 4.4.0-2
- Plages de versions concernées
- ECOSYSTEM: < 4.9.0-1
Mettez à jour vers 4.9.0-1
pycares PyPI
- Versions du logiciel
- 0.1.0
- 0.2.0
- 0.3.0
- 0.4.0
- 0.5.0
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- 0.7.0
- 1.0.0
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- 2.4.0
- 3.0.0
- 3.0.0b0
- 3.0.0b1
- 3.0.0b2
- 3.0.0b3
- 3.0.0b4
- 3.0.0b5
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.3
- 4.0.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.1
- 4.2.2
- 4.3.0
- 4.4.0
- 4.5.0
- 4.6.0
- 4.6.1
- 4.7.0
- 4.8.0
- Plages de versions concernées
- ECOSYSTEM: < 4.9.0
Mettez à jour vers 4.9.0
pycares Ubuntu:18.04:LTS
- Versions du logiciel
- 2.1.1-2build2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Ubuntu:20.04:LTS
- Versions du logiciel
- 2.1.1-2build4
- 2.1.1-2build5
- 2.1.1-2.1
- 3.1.0-3
- 3.1.0-4
- 3.1.1-1
- 3.1.1-1build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Ubuntu:22.04:LTS
- Versions du logiciel
- 3.1.1-1build3
- 3.1.1-1build5
- 4.1.2-2
- 4.1.2-2build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Ubuntu:24.04:LTS
- Versions du logiciel
- 4.3.0-2
- 4.3.0-2build1
- 4.4.0-1
- 4.4.0-1build1
- 4.4.0-1build2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Ubuntu:25.10
- Versions du logiciel
- 4.4.0-2build2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Ubuntu:26.10
- Versions du logiciel
- 5.0.1-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pycares Ubuntu:26.04:LTS
- Versions du logiciel
- 4.4.0-2build2
- 4.4.0-2build3
- 4.9.0-1
- 5.0.0-2
- 5.0.1-2
- 5.0.1-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/saghul/pycares/security/advisories/GHSA-5qpg-rh4j-qp35
- https://github.com/aio-libs/aiodns/commit/f259a6e3650555157af53ac2b39f2ff545321d55
- https://github.com/saghul/pycares/commit/ebfd7d71eb8e74bc1057a361ea79a5906db510d4
- https://github.com/aio-libs/aiodns/releases/tag/v3.5.0
- https://github.com/saghul/pycares/releases/tag/v4.9.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-48945