p PatchFirst

CVE-2025-48945

CVE-2025-48945 · pycares has a Use-After-Free Vulnerability

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

pycares is a Python module which provides an interface to c-ares. c-ares is a C library that performs DNS requests and name resolutions asynchronously. Prior to version 4.9.0, pycares is vulnerable to a use-after-free condition that occurs when a Channel object is garbage collected while DNS queries are still pending. This results in a fatal Python error and interpreter crash. The vulnerability has been fixed in pycares 4.9.0 by implementing a safe channel destruction mechanism.

CVSS 8.2 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • aiodns

    Softwareversionen
    • < 4.9.0: Betroffen

    Keine Korrektur veröffentlicht

  • pycares Debian:12

    Softwareversionen
    • 4.3.0-2
    • 4.4.0-1
    • 4.4.0-2
    • 4.9.0-1
    • 5.0.0-1
    • 5.0.0-2
    • 5.0.0-3
    • 5.0.1-1
    • 5.0.1-2
    • 5.0.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Debian:13

    Softwareversionen
    • 4.4.0-2
    • 4.9.0-1
    • 5.0.0-1
    • 5.0.0-2
    • 5.0.0-3
    • 5.0.1-1
    • 5.0.1-2
    • 5.0.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Debian:14

    Softwareversionen
    • 4.4.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.9.0-1

    Auf 4.9.0-1 aktualisieren

  • pycares PyPI

    Softwareversionen
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.7.0
    • 1.0.0
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 3.0.0
    • 3.0.0b0
    • 3.0.0b1
    • 3.0.0b2
    • 3.0.0b3
    • 3.0.0b4
    • 3.0.0b5
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.3
    • 4.0.0
    • 4.1.1
    • 4.1.2
    • 4.2.0
    • 4.2.1
    • 4.2.2
    • 4.3.0
    • 4.4.0
    • 4.5.0
    • 4.6.0
    • 4.6.1
    • 4.7.0
    • 4.8.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.9.0

    Auf 4.9.0 aktualisieren

  • pycares Ubuntu:18.04:LTS

    Softwareversionen
    • 2.1.1-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Ubuntu:20.04:LTS

    Softwareversionen
    • 2.1.1-2build4
    • 2.1.1-2build5
    • 2.1.1-2.1
    • 3.1.0-3
    • 3.1.0-4
    • 3.1.1-1
    • 3.1.1-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Ubuntu:22.04:LTS

    Softwareversionen
    • 3.1.1-1build3
    • 3.1.1-1build5
    • 4.1.2-2
    • 4.1.2-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Ubuntu:24.04:LTS

    Softwareversionen
    • 4.3.0-2
    • 4.3.0-2build1
    • 4.4.0-1
    • 4.4.0-1build1
    • 4.4.0-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Ubuntu:25.10

    Softwareversionen
    • 4.4.0-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Ubuntu:26.10

    Softwareversionen
    • 5.0.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pycares Ubuntu:26.04:LTS

    Softwareversionen
    • 4.4.0-2build2
    • 4.4.0-2build3
    • 4.9.0-1
    • 5.0.0-2
    • 5.0.1-2
    • 5.0.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →