CVE-2025-59472
CVE-2025-59472
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode. The PPR resume endpoint accepts unauthenticated POST requests with the `Next-Resume: 1` header and processes attacker-controlled postponed state data. Two closely related vulnerabilities allow an attacker to crash the server process through memory exhaustion: 1. **Unbounded request body buffering**: The server buffers the entire POST request body into memory using `Buffer.concat()` without enforcing any size limit, allowing arbitrarily large payloads to exhaust available memory. 2. **Unbounded decompression (zipbomb)**: The resume data cache is decompressed using `inflateSync()` without limiting the decompressed output size. A small compressed payload can expand to hundreds of megabytes or gigabytes, causing memory exhaustion. Both attack vectors result in a fatal V8 out-of-memory error (`FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory`) causing the Node.js process to terminate. The zipbomb variant is particularly dangerous as it can bypass reverse proxy request size limits while still causing large memory allocation on the server. To be affected you must have an application running with `experimental.ppr: true` or `cacheComponents: true` configured along with the NEXT_PRIVATE_MINIMAL_MODE=1 environment variable. Strongly consider upgrading to 15.6.0-canary.61 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
CVSS 5.9 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
next
- Versions du logiciel
- ≥ 15.0.0-canary.0, < 15.0.0: Concernée (semver)
- ≥ 15.0.1-canary.0, < 15.0.1: Concernée (semver)
- ≥ 15.0.2-canary.0, < 15.0.2: Concernée (semver)
- ≥ 15.0.3-canary.0, < 15.0.3: Concernée (semver)
- ≥ 15.0.4-canary.0, < 15.0.4: Concernée (semver)
- ≥ 15.1.0-canary.0, < 15.1.0: Concernée (semver)
- ≥ 15.1.1-canary.0, < 15.1.1: Concernée (semver)
- ≥ 15.1.2-canary.0, < 15.1.2: Concernée (semver)
- ≥ 15.1.3-canary.0, < 15.1.3: Concernée (semver)
- ≥ 15.1.4-canary.0, < 15.1.4: Concernée (semver)
- ≥ 15.1.5-canary.0, < 15.1.5: Concernée (semver)
- ≥ 15.1.6-canary.0, < 15.1.6: Concernée (semver)
- ≥ 15.1.7-canary.0, < 15.1.7: Concernée (semver)
- ≥ 15.2.0-canary.0, < 15.2.0: Concernée (semver)
- ≥ 15.2.1-canary.0, < 15.2.1: Concernée (semver)
- ≥ 15.2.2-canary.0, < 15.2.2: Concernée (semver)
- ≥ 15.2.3-canary.0, < 15.2.3: Concernée (semver)
- ≥ 15.2.4-canary.0, < 15.2.4: Concernée (semver)
- ≥ 15.2.5-canary.0, < 15.2.5: Concernée (semver)
- ≥ 15.3.0-canary.0, < 15.3.0: Concernée (semver)
- ≥ 15.3.1-canary.0, < 15.3.1: Concernée (semver)
- ≥ 15.3.2-canary.0, < 15.3.2: Concernée (semver)
- ≥ 15.1.8-canary.0, < 15.1.8: Concernée (semver)
- ≥ 15.3.3-canary.0, < 15.3.3: Concernée (semver)
- ≥ 15.4.0-canary.0, < 15.4.0: Concernée (semver)
- ≥ 15.3.4-canary.0, < 15.3.4: Concernée (semver)
- ≥ 15.3.5-canary.0, < 15.3.5: Concernée (semver)
- ≥ 15.4.1-canary.0, < 15.4.1: Concernée (semver)
- ≥ 15.4.2-canary.0, < 15.4.2: Concernée (semver)
- ≥ 15.4.3-canary.0, < 15.4.3: Concernée (semver)
- ≥ 15.4.4-canary.0, < 15.4.4: Concernée (semver)
- ≥ 15.4.5-canary.0, < 15.4.5: Concernée (semver)
- ≥ 15.4.6-canary.0, < 15.4.6: Concernée (semver)
- ≥ 15.4.7-canary.0, < 15.4.7: Concernée (semver)
- ≥ 15.5.0-canary.0, < 15.5.0: Concernée (semver)
- ≥ 15.5.1-canary.0, < 15.5.1: Concernée (semver)
- ≥ 15.5.2-canary.0, < 15.5.2: Concernée (semver)
- ≥ 15.5.3-canary.0, < 15.5.3: Concernée (semver)
- ≥ 15.5.4-canary.0, < 15.5.4: Concernée (semver)
- ≥ 15.5.5-canary.0, < 15.5.5: Concernée (semver)
- ≥ 15.5.6-canary.0, < 15.5.6: Concernée (semver)
- ≥ 15.5.7-canary.0, < 15.5.7: Concernée (semver)
- ≥ 15.4.8-canary.0, < 15.4.8: Concernée (semver)
- ≥ 15.1.9-canary.0, < 15.1.9: Concernée (semver)
Mettez à jour vers 15.0.0; Mettez à jour vers 15.0.1; Mettez à jour vers 15.0.2; Mettez à jour vers 15.0.3; Mettez à jour vers 15.0.4; Mettez à jour vers 15.0.5; Mettez à jour vers 15.0.6; Mettez à jour vers 15.0.7; Mettez à jour vers 15.1.0; Mettez à jour vers 15.1.1; Mettez à jour vers 15.1.10; Mettez à jour vers 15.1.11; Mettez à jour vers 15.1.2; Mettez à jour vers 15.1.3; Mettez à jour vers 15.1.4; Mettez à jour vers 15.1.5; Mettez à jour vers 15.1.6; Mettez à jour vers 15.1.7; Mettez à jour vers 15.1.8; Mettez à jour vers 15.1.9; Mettez à jour vers 15.2.0; Mettez à jour vers 15.2.1; Mettez à jour vers 15.2.2; Mettez à jour vers 15.2.3
next npm
- Plages de versions concernées
- SEMVER: ≥ 16.0.0-beta.0, < 16.1.5
Mettez à jour vers 16.1.5
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.0.0-canary.0, ≤ 15.0.0-canary.205
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.0.1-canary.0, ≤ 15.0.1-canary.3
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.0.2-canary.0, ≤ 15.0.2-canary.11
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.0.3-canary.0, ≤ 15.0.3-canary.9
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.0.4-canary.0, ≤ 15.0.4-canary.52
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.1.1-canary.0, ≤ 15.1.1-canary.27
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.2.0-canary.0, ≤ 15.2.0-canary.77
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.2.1-canary.0, ≤ 15.2.1-canary.6
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.2.2-canary.0, ≤ 15.2.2-canary.7
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.3.0-canary.0, ≤ 15.3.0-canary.46
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.3.1-canary.0, ≤ 15.3.1-canary.15
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.4.0-canary.0, ≤ 15.4.0-canary.130
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.4.2-canary.0, ≤ 15.4.2-canary.56
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.5.1-canary.0, ≤ 15.5.1-canary.39
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.6.0-canary.0, < 15.6.0-canary.61
Mettez à jour vers 15.6.0-canary.61