CVE-2025-59472
CVE-2025-59472
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode. The PPR resume endpoint accepts unauthenticated POST requests with the `Next-Resume: 1` header and processes attacker-controlled postponed state data. Two closely related vulnerabilities allow an attacker to crash the server process through memory exhaustion: 1. **Unbounded request body buffering**: The server buffers the entire POST request body into memory using `Buffer.concat()` without enforcing any size limit, allowing arbitrarily large payloads to exhaust available memory. 2. **Unbounded decompression (zipbomb)**: The resume data cache is decompressed using `inflateSync()` without limiting the decompressed output size. A small compressed payload can expand to hundreds of megabytes or gigabytes, causing memory exhaustion. Both attack vectors result in a fatal V8 out-of-memory error (`FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory`) causing the Node.js process to terminate. The zipbomb variant is particularly dangerous as it can bypass reverse proxy request size limits while still causing large memory allocation on the server. To be affected you must have an application running with `experimental.ppr: true` or `cacheComponents: true` configured along with the NEXT_PRIVATE_MINIMAL_MODE=1 environment variable. Strongly consider upgrading to 15.6.0-canary.61 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
CVSS 5.9 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
next
- Softwareversionen
- ≥ 15.0.0-canary.0, < 15.0.0: Betroffen (semver)
- ≥ 15.0.1-canary.0, < 15.0.1: Betroffen (semver)
- ≥ 15.0.2-canary.0, < 15.0.2: Betroffen (semver)
- ≥ 15.0.3-canary.0, < 15.0.3: Betroffen (semver)
- ≥ 15.0.4-canary.0, < 15.0.4: Betroffen (semver)
- ≥ 15.1.0-canary.0, < 15.1.0: Betroffen (semver)
- ≥ 15.1.1-canary.0, < 15.1.1: Betroffen (semver)
- ≥ 15.1.2-canary.0, < 15.1.2: Betroffen (semver)
- ≥ 15.1.3-canary.0, < 15.1.3: Betroffen (semver)
- ≥ 15.1.4-canary.0, < 15.1.4: Betroffen (semver)
- ≥ 15.1.5-canary.0, < 15.1.5: Betroffen (semver)
- ≥ 15.1.6-canary.0, < 15.1.6: Betroffen (semver)
- ≥ 15.1.7-canary.0, < 15.1.7: Betroffen (semver)
- ≥ 15.2.0-canary.0, < 15.2.0: Betroffen (semver)
- ≥ 15.2.1-canary.0, < 15.2.1: Betroffen (semver)
- ≥ 15.2.2-canary.0, < 15.2.2: Betroffen (semver)
- ≥ 15.2.3-canary.0, < 15.2.3: Betroffen (semver)
- ≥ 15.2.4-canary.0, < 15.2.4: Betroffen (semver)
- ≥ 15.2.5-canary.0, < 15.2.5: Betroffen (semver)
- ≥ 15.3.0-canary.0, < 15.3.0: Betroffen (semver)
- ≥ 15.3.1-canary.0, < 15.3.1: Betroffen (semver)
- ≥ 15.3.2-canary.0, < 15.3.2: Betroffen (semver)
- ≥ 15.1.8-canary.0, < 15.1.8: Betroffen (semver)
- ≥ 15.3.3-canary.0, < 15.3.3: Betroffen (semver)
- ≥ 15.4.0-canary.0, < 15.4.0: Betroffen (semver)
- ≥ 15.3.4-canary.0, < 15.3.4: Betroffen (semver)
- ≥ 15.3.5-canary.0, < 15.3.5: Betroffen (semver)
- ≥ 15.4.1-canary.0, < 15.4.1: Betroffen (semver)
- ≥ 15.4.2-canary.0, < 15.4.2: Betroffen (semver)
- ≥ 15.4.3-canary.0, < 15.4.3: Betroffen (semver)
- ≥ 15.4.4-canary.0, < 15.4.4: Betroffen (semver)
- ≥ 15.4.5-canary.0, < 15.4.5: Betroffen (semver)
- ≥ 15.4.6-canary.0, < 15.4.6: Betroffen (semver)
- ≥ 15.4.7-canary.0, < 15.4.7: Betroffen (semver)
- ≥ 15.5.0-canary.0, < 15.5.0: Betroffen (semver)
- ≥ 15.5.1-canary.0, < 15.5.1: Betroffen (semver)
- ≥ 15.5.2-canary.0, < 15.5.2: Betroffen (semver)
- ≥ 15.5.3-canary.0, < 15.5.3: Betroffen (semver)
- ≥ 15.5.4-canary.0, < 15.5.4: Betroffen (semver)
- ≥ 15.5.5-canary.0, < 15.5.5: Betroffen (semver)
- ≥ 15.5.6-canary.0, < 15.5.6: Betroffen (semver)
- ≥ 15.5.7-canary.0, < 15.5.7: Betroffen (semver)
- ≥ 15.4.8-canary.0, < 15.4.8: Betroffen (semver)
- ≥ 15.1.9-canary.0, < 15.1.9: Betroffen (semver)
Auf 15.0.0 aktualisieren; Auf 15.0.1 aktualisieren; Auf 15.0.2 aktualisieren; Auf 15.0.3 aktualisieren; Auf 15.0.4 aktualisieren; Auf 15.0.5 aktualisieren; Auf 15.0.6 aktualisieren; Auf 15.0.7 aktualisieren; Auf 15.1.0 aktualisieren; Auf 15.1.1 aktualisieren; Auf 15.1.10 aktualisieren; Auf 15.1.11 aktualisieren; Auf 15.1.2 aktualisieren; Auf 15.1.3 aktualisieren; Auf 15.1.4 aktualisieren; Auf 15.1.5 aktualisieren; Auf 15.1.6 aktualisieren; Auf 15.1.7 aktualisieren; Auf 15.1.8 aktualisieren; Auf 15.1.9 aktualisieren; Auf 15.2.0 aktualisieren; Auf 15.2.1 aktualisieren; Auf 15.2.2 aktualisieren; Auf 15.2.3 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 16.0.0-beta.0, < 16.1.5
Auf 16.1.5 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.0.0-canary.0, ≤ 15.0.0-canary.205
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.0.1-canary.0, ≤ 15.0.1-canary.3
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.0.2-canary.0, ≤ 15.0.2-canary.11
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.0.3-canary.0, ≤ 15.0.3-canary.9
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.0.4-canary.0, ≤ 15.0.4-canary.52
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.1.1-canary.0, ≤ 15.1.1-canary.27
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.2.0-canary.0, ≤ 15.2.0-canary.77
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.2.1-canary.0, ≤ 15.2.1-canary.6
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.2.2-canary.0, ≤ 15.2.2-canary.7
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.3.0-canary.0, ≤ 15.3.0-canary.46
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.3.1-canary.0, ≤ 15.3.1-canary.15
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.4.0-canary.0, ≤ 15.4.0-canary.130
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.4.2-canary.0, ≤ 15.4.2-canary.56
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.5.1-canary.0, ≤ 15.5.1-canary.39
Keine Korrektur veröffentlicht
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.6.0-canary.0, < 15.6.0-canary.61
Auf 15.6.0-canary.61 aktualisieren