p PatchFirst

CVE-2025-59528

CVE-2025-59528 · Flowise has Remote Code Execution vulnerability

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, Flowise is vulnerable to remote code execution. The CustomMCP node allows users to input configuration settings for connecting to an external MCP server. This node parses the user-provided mcpServerConfig string to build the MCP server configuration. However, during this process, it executes JavaScript code without any security validation. Specifically, inside the convertToValidJSONString function, user input is directly passed to the Function() constructor, which evaluates and executes the input as JavaScript code. Since this runs with full Node.js runtime privileges, it can access dangerous modules such as child_process and fs. This issue has been patched in version 3.0.6.

CVSS 10.0 · Critique · EPSS 86,2% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • flowise

    Versions du logiciel
    • = 3.0.5: Concernée

    Aucun correctif publié

  • flowise npm

    Versions du logiciel
    • 3.0.5
    Plages de versions concernées
    • SEMVER: ≥ 3.0.5, < 3.0.6

    Mettez à jour vers 3.0.6

Sources originales

Vérifiez votre serveur →