p PatchFirst

CVE-2025-59528

CVE-2025-59528 · Flowise has Remote Code Execution vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, Flowise is vulnerable to remote code execution. The CustomMCP node allows users to input configuration settings for connecting to an external MCP server. This node parses the user-provided mcpServerConfig string to build the MCP server configuration. However, during this process, it executes JavaScript code without any security validation. Specifically, inside the convertToValidJSONString function, user input is directly passed to the Function() constructor, which evaluates and executes the input as JavaScript code. Since this runs with full Node.js runtime privileges, it can access dangerous modules such as child_process and fs. This issue has been patched in version 3.0.6.

CVSS 10.0 · Critical · EPSS 86.2% · Public exploit · Fix available

Published
Updated

Stack: node

Affected products and versions

  • flowise

    Versions
    • = 3.0.5: Affected

    No fix published

  • flowise npm

    Versions
    • 3.0.5
    Affected ranges
    • SEMVER: ≥ 3.0.5, < 3.0.6

    Update to 3.0.6

Original sources

Check your server →