CVE-2025-64506
CVE-2025-64506 · LIBPNG is vulnerable to a heap buffer over-read in `png_write_image_8bit` with grayscale+alpha or RGB/RGBA images
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_write_image_8bit function when processing 8-bit images through the simplified write API with convert_to_8bit enabled. The vulnerability affects 8-bit grayscale+alpha, RGB/RGBA, and images with incomplete row data. A conditional guard incorrectly allows 8-bit input to enter code expecting 16-bit input, causing reads up to 2 bytes beyond allocated buffer boundaries. This issue has been patched in version 1.6.51.
CVSS 6.1 · Moyenne · EPSS 0,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libpng
- Versions du logiciel
- >= 1.6.0, < 1.6.51: Concernée
Aucun correctif publié
libpng1.6 Debian:12
- Versions du logiciel
- 1.6.39-2
- Plages de versions concernées
- ECOSYSTEM: < 1.6.39-2+deb12u1
Mettez à jour vers 1.6.39-2+deb12u1
libpng1.6 Debian:13
- Versions du logiciel
- 1.6.48-1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.48-1+deb13u1
Mettez à jour vers 1.6.48-1+deb13u1
libpng1.6 Debian:14
- Versions du logiciel
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.51-1
Mettez à jour vers 1.6.51-1
libpng1.6 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm2
Mettez à jour vers 1.6.20-2ubuntu0.1~esm2
libpng1.6 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- Plages de versions concernées
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm1
Mettez à jour vers 1.6.34-1ubuntu0.18.04.2+esm1
libpng1.6 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.6.37-1
- 1.6.37-2
- Plages de versions concernées
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm1
Mettez à jour vers 1.6.37-2ubuntu0.1~esm1
libpng1.6 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.6.37-3build4
- 1.6.37-3build5
- Plages de versions concernées
- ECOSYSTEM: < 1.6.37-3ubuntu0.1
Mettez à jour vers 1.6.37-3ubuntu0.1
libpng1.6 Ubuntu:24.04:LTS
- Versions du logiciel
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.43-5ubuntu0.1
Mettez à jour vers 1.6.43-5ubuntu0.1
libpng1.6 Ubuntu:25.10
- Versions du logiciel
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.50-1ubuntu0.1
Mettez à jour vers 1.6.50-1ubuntu0.1