p PatchFirst

CVE-2025-64506

CVE-2025-64506 · LIBPNG is vulnerable to a heap buffer over-read in `png_write_image_8bit` with grayscale+alpha or RGB/RGBA images

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_write_image_8bit function when processing 8-bit images through the simplified write API with convert_to_8bit enabled. The vulnerability affects 8-bit grayscale+alpha, RGB/RGBA, and images with incomplete row data. A conditional guard incorrectly allows 8-bit input to enter code expecting 16-bit input, causing reads up to 2 bytes beyond allocated buffer boundaries. This issue has been patched in version 1.6.51.

CVSS 6.1 · Mittel · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libpng

    Softwareversionen
    • >= 1.6.0, < 1.6.51: Betroffen

    Keine Korrektur veröffentlicht

  • libpng1.6 Debian:12

    Softwareversionen
    • 1.6.39-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.39-2+deb12u1

    Auf 1.6.39-2+deb12u1 aktualisieren

  • libpng1.6 Debian:13

    Softwareversionen
    • 1.6.48-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.48-1+deb13u1

    Auf 1.6.48-1+deb13u1 aktualisieren

  • libpng1.6 Debian:14

    Softwareversionen
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1
    • 1.6.50-1~exp1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.51-1

    Auf 1.6.51-1 aktualisieren

  • libpng1.6 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6.20-2
    • 1.6.20-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm2

    Auf 1.6.20-2ubuntu0.1~esm2 aktualisieren

  • libpng1.6 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.6.34-1
    • 1.6.34-1ubuntu0.18.04.1
    • 1.6.34-1ubuntu0.18.04.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm1

    Auf 1.6.34-1ubuntu0.18.04.2+esm1 aktualisieren

  • libpng1.6 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.6.37-1
    • 1.6.37-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm1

    Auf 1.6.37-2ubuntu0.1~esm1 aktualisieren

  • libpng1.6 Ubuntu:22.04:LTS

    Softwareversionen
    • 1.6.37-3build4
    • 1.6.37-3build5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.37-3ubuntu0.1

    Auf 1.6.37-3ubuntu0.1 aktualisieren

  • libpng1.6 Ubuntu:24.04:LTS

    Softwareversionen
    • 1.6.40-1
    • 1.6.40-2
    • 1.6.40-3
    • 1.6.42-1
    • 1.6.43-1
    • 1.6.43-3
    • 1.6.43-5build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.43-5ubuntu0.1

    Auf 1.6.43-5ubuntu0.1 aktualisieren

  • libpng1.6 Ubuntu:25.10

    Softwareversionen
    • 1.6.47-1.1
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1~exp1
    • 1.6.50-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.50-1ubuntu0.1

    Auf 1.6.50-1ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →