CVE-2026-102832
CVE-2026-102832 · JupyterLab: Command link trust prompt in JupyterLab can trust a document other than the one clicked
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.7 until 4.5.11 and 4.6.4, the markdownviewer:trust and notebook:trust command-link handlers use tracker.currentWidget to resolve the current Markdown viewer or notebook when the user answers rather than retaining the document whose command button was clicked. If another document becomes current while the prompt is open and the user chooses Trust, JupyterLab marks the second document trusted while leaving the clicked document untrusted. Later command buttons in the incorrectly trusted document run without a prompt, and trusting a notebook marks all cells trusted, saves unsaved edits, and persists the server signature to disk. Applications that bundle JupyterLab, including affected Notebook and JupyterLite releases, inherit the behavior. This issue is fixed in versions 4.5.11 and 4.6.4.
CVSS 4.2 · Moyenne · EPSS 0,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
jupyterlab
- Versions du logiciel
- >= 4.5.7, < 4.5.11: Concernée
- >= 4.6.0, < 4.6.4: Concernée
Aucun correctif publié
jupyterlite-core
- Versions du logiciel
- >= 0.7.5, < 0.8.4: Concernée
Aucun correctif publié
notebook
- Versions du logiciel
- >= 7.5.6, < 7.6.3: Concernée
Aucun correctif publié
jupyterlab PyPI
- Versions du logiciel
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- Plages de versions concernées
- ECOSYSTEM: ≥ 4.6.0, < 4.6.4
Mettez à jour vers 4.6.4
jupyterlab PyPI
- Versions du logiciel
- 4.5.10
- 4.5.7
- 4.5.8
- 4.5.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 4.5.7, < 4.5.11
Mettez à jour vers 4.5.11
notebook PyPI
- Versions du logiciel
- 7.5.6
- 7.5.7
- 7.5.8
- 7.6.0
- 7.6.0a0
- 7.6.0a1
- 7.6.0a2
- 7.6.0a3
- 7.6.0a4
- 7.6.0a5
- 7.6.0b0
- 7.6.0b1
- 7.6.0rc0
- 7.6.0rc1
- 7.6.1
- 7.6.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 7.5.6, < 7.6.3
Mettez à jour vers 7.6.3
jupyterlite-core PyPI
- Versions du logiciel
- 0.7.5
- 0.7.6
- 0.8.0
- 0.8.0a0
- 0.8.0a1
- 0.8.0a2
- 0.8.0b0
- 0.8.0b1
- 0.8.0rc0
- 0.8.1
- 0.8.2
- 0.8.3
- Plages de versions concernées
- ECOSYSTEM: ≥ 0.7.5, < 0.8.4
Mettez à jour vers 0.8.4
jupyterlab Ubuntu:26.10
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-9
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterlab Ubuntu:26.04:LTS
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-jwrc-gm9j-263p
- https://github.com/jupyterlab/jupyterlab/commit/0fc18ab4ef67e431a8f6560e387193baf786c70a
- https://github.com/jupyterlab/jupyterlab/commit/b64bc88b8ca034cf158604a5cc48ca9170ea453b
- https://github.com/jupyterlab/jupyterlab/commit/f7e5f9803fdf2aaaa0e9bfb9cc73386a8cc5f0b2
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4
- https://nvd.nist.gov/vuln/detail/CVE-2026-102832