p PatchFirst

CVE-2026-102832

CVE-2026-102832 · JupyterLab: Command link trust prompt in JupyterLab can trust a document other than the one clicked

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.7 until 4.5.11 and 4.6.4, the markdownviewer:trust and notebook:trust command-link handlers use tracker.currentWidget to resolve the current Markdown viewer or notebook when the user answers rather than retaining the document whose command button was clicked. If another document becomes current while the prompt is open and the user chooses Trust, JupyterLab marks the second document trusted while leaving the clicked document untrusted. Later command buttons in the incorrectly trusted document run without a prompt, and trusting a notebook marks all cells trusted, saves unsaved edits, and persists the server signature to disk. Applications that bundle JupyterLab, including affected Notebook and JupyterLite releases, inherit the behavior. This issue is fixed in versions 4.5.11 and 4.6.4.

CVSS 4.2 · Mittel · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • jupyterlab

    Softwareversionen
    • >= 4.5.7, < 4.5.11: Betroffen
    • >= 4.6.0, < 4.6.4: Betroffen

    Keine Korrektur veröffentlicht

  • jupyterlite-core

    Softwareversionen
    • >= 0.7.5, < 0.8.4: Betroffen

    Keine Korrektur veröffentlicht

  • notebook

    Softwareversionen
    • >= 7.5.6, < 7.6.3: Betroffen

    Keine Korrektur veröffentlicht

  • jupyterlab PyPI

    Softwareversionen
    • 4.6.0
    • 4.6.1
    • 4.6.2
    • 4.6.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.6.0, < 4.6.4

    Auf 4.6.4 aktualisieren

  • jupyterlab PyPI

    Softwareversionen
    • 4.5.10
    • 4.5.7
    • 4.5.8
    • 4.5.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.5.7, < 4.5.11

    Auf 4.5.11 aktualisieren

  • notebook PyPI

    Softwareversionen
    • 7.5.6
    • 7.5.7
    • 7.5.8
    • 7.6.0
    • 7.6.0a0
    • 7.6.0a1
    • 7.6.0a2
    • 7.6.0a3
    • 7.6.0a4
    • 7.6.0a5
    • 7.6.0b0
    • 7.6.0b1
    • 7.6.0rc0
    • 7.6.0rc1
    • 7.6.1
    • 7.6.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 7.5.6, < 7.6.3

    Auf 7.6.3 aktualisieren

  • jupyterlite-core PyPI

    Softwareversionen
    • 0.7.5
    • 0.7.6
    • 0.8.0
    • 0.8.0a0
    • 0.8.0a1
    • 0.8.0a2
    • 0.8.0b0
    • 0.8.0b1
    • 0.8.0rc0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.7.5, < 0.8.4

    Auf 0.8.4 aktualisieren

  • jupyterlab Ubuntu:26.10

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterlab Ubuntu:26.04:LTS

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →