p PatchFirst

CVE-2026-106440

CVE-2026-106440 · Hydra: Optuna custom_search_space can resolve and execute untrusted callables via get_method

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Hydra is a framework for elegantly configuring complex applications. From 1.2.0 until 1.3.0 and 1.4.0.dev10, the hydra-optuna-sweeper package accepts a configuration-controlled dotted path in hydra.sweeper.custom_search_space, resolves it with hydra.utils.get_method(), and later invokes the returned callable in the Hydra controller process. Because get_method() is a trusted-input lookup helper and does not apply the execution policy used by instantiate(), an attacker who controls Optuna sweep configuration or command-line overrides can select importable Python code for execution with the application's privileges, including bypassing a trusted execution whitelist on affected Hydra 1.4 development releases. This issue is fixed in versions 1.3.0 and 1.4.0.dev10.

CVSS 7.8 · Élevée · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • hydra

    Versions du logiciel
    • >= 1.2.0, < 1.3.0: Concernée
    • >= 1.4.0.dev4, < 1.4.0.dev10: Concernée

    Aucun correctif publié

  • hydra-optuna-sweeper PyPI

    Versions du logiciel
    • 1.2.0
    • 1.3.0.dev0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.2.0, < 1.3.0

    Mettez à jour vers 1.3.0

  • hydra-optuna-sweeper PyPI

    Versions du logiciel
    • 1.4.0.dev4
    • 1.4.0.dev5
    • 1.4.0.dev6
    • 1.4.0.dev7
    • 1.4.0.dev8
    • 1.4.0.dev9
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.4.0.dev4, < 1.4.0.dev10

    Mettez à jour vers 1.4.0.dev10

  • hydra-optuna-sweeper PyPI

    Versions du logiciel
    • 1.2.0
    • 1.3.0.dev0
    • 1.4.0.dev4
    • 1.4.0.dev5
    • 1.4.0.dev6
    • 1.4.0.dev7
    • 1.4.0.dev8
    • 1.4.0.dev9
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.2.0, < 1.3.0 ∪ ≥ 1.4.0.dev4, < 1.4.0.dev10

    Mettez à jour vers 1.3.0; Mettez à jour vers 1.4.0.dev10

Sources originales

Vérifiez votre serveur →