p PatchFirst

CVE-2026-106440

CVE-2026-106440 · Hydra: Optuna custom_search_space can resolve and execute untrusted callables via get_method

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Hydra is a framework for elegantly configuring complex applications. From 1.2.0 until 1.3.0 and 1.4.0.dev10, the hydra-optuna-sweeper package accepts a configuration-controlled dotted path in hydra.sweeper.custom_search_space, resolves it with hydra.utils.get_method(), and later invokes the returned callable in the Hydra controller process. Because get_method() is a trusted-input lookup helper and does not apply the execution policy used by instantiate(), an attacker who controls Optuna sweep configuration or command-line overrides can select importable Python code for execution with the application's privileges, including bypassing a trusted execution whitelist on affected Hydra 1.4 development releases. This issue is fixed in versions 1.3.0 and 1.4.0.dev10.

CVSS 7.8 · Hoch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • hydra

    Softwareversionen
    • >= 1.2.0, < 1.3.0: Betroffen
    • >= 1.4.0.dev4, < 1.4.0.dev10: Betroffen

    Keine Korrektur veröffentlicht

  • hydra-optuna-sweeper PyPI

    Softwareversionen
    • 1.2.0
    • 1.3.0.dev0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.2.0, < 1.3.0

    Auf 1.3.0 aktualisieren

  • hydra-optuna-sweeper PyPI

    Softwareversionen
    • 1.4.0.dev4
    • 1.4.0.dev5
    • 1.4.0.dev6
    • 1.4.0.dev7
    • 1.4.0.dev8
    • 1.4.0.dev9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.4.0.dev4, < 1.4.0.dev10

    Auf 1.4.0.dev10 aktualisieren

  • hydra-optuna-sweeper PyPI

    Softwareversionen
    • 1.2.0
    • 1.3.0.dev0
    • 1.4.0.dev4
    • 1.4.0.dev5
    • 1.4.0.dev6
    • 1.4.0.dev7
    • 1.4.0.dev8
    • 1.4.0.dev9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.2.0, < 1.3.0 ∪ ≥ 1.4.0.dev4, < 1.4.0.dev10

    Auf 1.3.0 aktualisieren; Auf 1.4.0.dev10 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →