CVE-2026-114135
CVE-2026-114135 · Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Jupyter Server is the backend for Jupyter web applications. From 2.0.0 until 2.6.0, enabling GatewayClient.url replaced the normal KernelWebsocketHandler with WebSocketChannelsHandler, which authenticated the user but did not call authorizer.is_authorized(...) for the execute action on the kernels resource. A restricted authenticated user could therefore open an upstream kernel channel and obtain kernel execution despite the configured Authorizer denying that action, exposing data and credentials available to the kernel and permitting modification or disruption of the kernel environment. The default gateway configuration is fixed in version 2.6.0. In 2.6.0 and later, the same authorization bypass remains possible when a deployment manually registers the deprecated jupyter_server.gateway.handlers module, because its handler still omits the configured kernel-execute authorization decision.
CVSS 8.8 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
jupyter_server
- Versions du logiciel
- >= 2.0.0, < 2.6.0: Concernée
Aucun correctif publié
jupyter-server Debian:12
- Versions du logiciel
- 1.23.3-1
- 1.23.3-2
- 2.14.0-1
- 2.14.2-1
- 2.14.2-2
- 2.14.2-3
- 2.14.2-4
- 2.14.2-5
- 2.15.0-1
- 2.17.0-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-3
- 2.9.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyter-server Debian:13
- Versions du logiciel
- 2.15.0-1
- 2.17.0-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyter-server Debian:14
- Versions du logiciel
- 2.15.0-1
- 2.17.0-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyter-server PyPI
- Versions du logiciel
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.5.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 2.6.0
Mettez à jour vers 2.6.0
jupyter-server Ubuntu:22.04:LTS
- Versions du logiciel
- 1.2.2-1
- 1.13.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyter-server Ubuntu:24.04:LTS
- Versions du logiciel
- 1.23.3-1
- 1.23.3-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyter-server Ubuntu:26.10
- Versions du logiciel
- 2.17.0-1
- 2.20.0-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyter-server Ubuntu:26.04:LTS
- Versions du logiciel
- 2.15.0-1
- 2.17.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-354v-3q48-cv69
- https://github.com/jupyter-server/jupyter_server/pull/1261
- https://github.com/jupyter-server/jupyter_server/commit/35ffe5d435682128da16dc144a8e9e9f8fa85dd8
- https://github.com/jupyter-server/jupyter_server/releases/tag/v2.6.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-114135